Last Comment Bug 712414 - Throbber does not stop after running on pages that use document.write without document.close
: Throbber does not stop after running on pages that use document.write without...
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 12
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks: 710297
  Show dependency treegraph
 
Reported: 2011-12-20 13:23 PST by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2012-01-10 14:16 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (3.19 KB, patch)
2011-12-21 08:20 PST, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-20 13:23:33 PST
1. download the startup5.html
2. adb push startup5.html /sdcard/download
3. am start -a android.intent.action.VIEW -n org.mozilla.fennec/.App -d file://mnt/sdcard/download/startup5.html#63728494

Expected: throbber will stop at some point in time
Actual: the throbber keeps going

Note:
20111220 build
Comment 1 Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-20 14:08:46 PST
The build is wrong : http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-r7/

However, I cannot test to see if this still occurs because of : bug 712163 is blocking all s0/s1 testing.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-21 08:20:35 PST
Created attachment 583508 [details] [diff] [review]
patch

The startup5.html file uses document.write() but never does a document.close() and I think we never get a DOCUMENT stop notificiation.

This patch switches Fennec to use NETWORK start and stop instead of DOCUMENT start and stop. Desktop Firefox also uses NETWORK:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#4547
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-21 13:54:34 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/c82245ed1e82
Comment 4 Ed Morley [:emorley] 2011-12-22 03:50:59 PST
https://hg.mozilla.org/mozilla-central/rev/c82245ed1e82
Comment 5 Jesse Ruderman 2011-12-27 23:37:01 PST
Why has Fennec decided to differ from Firefox here?  Firefox leaves the throbber spinning; see bug 81980.  (And see bug 605937...)
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-03 22:30:54 PST
(In reply to Jesse Ruderman from comment #5)
> Why has Fennec decided to differ from Firefox here?  Firefox leaves the
> throbber spinning; see bug 81980.  (And see bug 605937...)

Jesse - ironically, we wanted to match how desktop Firefox handled the page in question.
Comment 7 Catalin Suciu [:csuciu] 2012-01-05 06:03:09 PST
Verified fixed on Native Fennec 12.0a1 build 20120104031035.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-06 23:16:32 PST
Comment on attachment 583508 [details] [diff] [review]
patch

[Approval Request Comment]
We want this behavior so we don't appear to be taking forever to load
Comment 9 Alex Keybl [:akeybl] 2012-01-09 14:53:51 PST
Comment on attachment 583508 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-10 14:16:43 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/f09ae3fa7790

Note You need to log in before you can comment on or make changes to this bug.