Last Comment Bug 712300 - Checkerboard over about:home footer area
: Checkerboard over about:home footer area
Status: VERIFIED FIXED
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 12
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 710333 712567 713037 713879 714155 715617 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-20 06:51 PST by Aaron Train [:aaronmt]
Modified: 2012-01-09 12:04 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed
verified


Attachments
Nightly (12/20) - about:home (199.53 KB, image/png)
2011-12-20 06:51 PST, Aaron Train [:aaronmt]
no flags Details
patch (1.47 KB, patch)
2011-12-20 21:23 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-12-20 06:51:40 PST
Created attachment 583150 [details]
Nightly (12/20) - about:home

about:home's footer area has significant checker-boarding 

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d75ebb37080e&tochange=2afd7ae68e8b

--
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111220 Firefox/11.0a1 Fennec/11.0a1
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2011-12-20 21:23:27 PST
Created attachment 583390 [details] [diff] [review]
patch
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-20 22:54:18 PST
Comment on attachment 583390 [details] [diff] [review]
patch

Could we do this via XML layout? Code is OK, but I'm just looking for a way to keep some of the tweaks out of code.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-20 22:54:57 PST
I bet we can't since we moved the about home container out of layout XML, right?
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2011-12-20 22:58:42 PST
(In reply to Mark Finkle (:mfinkle) from comment #3)
> I bet we can't since we moved the about home container out of layout XML,
> right?

yup
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2011-12-20 23:31:02 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/e0ffc90ae4a4
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-21 05:48:27 PST
*** Bug 710333 has been marked as a duplicate of this bug. ***
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-21 05:57:45 PST
*** Bug 712567 has been marked as a duplicate of this bug. ***
Comment 8 Ed Morley [:emorley] 2011-12-21 12:54:59 PST
https://hg.mozilla.org/mozilla-central/rev/e0ffc90ae4a4
Comment 9 Brad Lassey [:blassey] (use needinfo?) 2011-12-22 11:51:44 PST
*** Bug 713037 has been marked as a duplicate of this bug. ***
Comment 10 Carla Nadastean 2011-12-27 05:32:23 PST
Verified with: 
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20111227 Firefox/12.0a1 Fennec/12.0a1
HTC Desire Z (Android 2.3)

Bug no longer reproducible: checkerboard no longer displayed in about:home page.
Comment 11 Aaron Train [:aaronmt] 2011-12-28 09:14:32 PST
*** Bug 713879 has been marked as a duplicate of this bug. ***
Comment 12 Brad Lassey [:blassey] (use needinfo?) 2011-12-29 13:13:45 PST
*** Bug 714155 has been marked as a duplicate of this bug. ***
Comment 13 Aaron Train [:aaronmt] 2012-01-06 06:25:16 PST
Comment on attachment 583390 [details] [diff] [review]
patch

[Approval Request Comment]
about:home looks really poor without this fix, footer area is checker-boarded
Comment 14 Aaron Train [:aaronmt] 2012-01-06 06:26:10 PST
*** Bug 715617 has been marked as a duplicate of this bug. ***
Comment 15 Alex Keybl [:akeybl] 2012-01-06 11:01:28 PST
Comment on attachment 583390 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 16 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-06 23:30:13 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/a215bdf79c9a

Note You need to log in before you can comment on or make changes to this bug.