Last Comment Bug 712536 - null pointer crash when rotating about:home
: null pointer crash when rotating about:home
Status: RESOLVED FIXED
[native-crash]
: crash
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- critical (vote)
: Firefox 12
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 721340 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-20 20:32 PST by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-01-26 17:18 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (929 bytes, patch)
2011-12-20 21:20 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-12-20 20:32:02 PST
I/GeckoApp(31723): Got message: DOMContentLoaded
I/GeckoTab(31723): Updated title: Fennec Start for tab with id: 1
I/GeckoApp(31723): URI - about:home, title - Fennec Start
E/GeckoApp(31723): top level exception
E/GeckoApp(31723): java.lang.NullPointerException
E/GeckoApp(31723): 	at org.mozilla.gecko.AboutHomeContent.onConfigurationChanged(AboutHomeContent.java:219)
E/GeckoApp(31723): 	at android.view.View.dispatchConfigurationChanged(View.java:4120)
E/GeckoApp(31723): 	at android.view.ViewGroup.dispatchConfigurationChanged(ViewGroup.java:729)
E/GeckoApp(31723): 	at android.view.ViewGroup.dispatchConfigurationChanged(ViewGroup.java:733)
E/GeckoApp(31723): 	at android.view.ViewGroup.dispatchConfigurationChanged(ViewGroup.java:733)
E/GeckoApp(31723): 	at android.view.ViewGroup.dispatchConfigurationChanged(ViewGroup.java:733)
E/GeckoApp(31723): 	at android.view.ViewGroup.dispatchConfigurationChanged(ViewGroup.java:733)
E/GeckoApp(31723): 	at android.view.ViewRoot.updateConfiguration(ViewRoot.java:1805)
E/GeckoApp(31723): 	at android.view.ViewRoot.handleMessage(ViewRoot.java:1924)
E/GeckoApp(31723): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/GeckoApp(31723): 	at android.os.Looper.loop(Looper.java:130)
E/GeckoApp(31723): 	at org.mozilla.gecko.GeckoApp$33.run(GeckoApp.java:1512)
E/GeckoApp(31723): 	at android.os.Handler.handleCallback(Handler.java:587)
E/GeckoApp(31723): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoApp(31723): 	at android.os.Looper.loop(Looper.java:130)
E/GeckoApp(31723): 	at android.app.ActivityThread.main(ActivityThread.java:3835)
E/GeckoApp(31723): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoApp(31723): 	at java.lang.reflect.Method.invoke(Method.java:507)
E/GeckoApp(31723): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:847)
E/GeckoApp(31723): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:605)
E/GeckoApp(31723): 	at dalvik.system.NativeStart.main(Native Method)
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2011-12-20 21:20:11 PST
Created attachment 583388 [details] [diff] [review]
patch
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2011-12-20 23:32:04 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/0b3e8d34fbc5
Comment 3 Ed Morley [:emorley] 2011-12-21 12:55:38 PST
(Scoobidiver, this landed for 12, not 11)

https://hg.mozilla.org/mozilla-central/rev/0b3e8d34fbc5
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-06 23:19:39 PST
Comment on attachment 583388 [details] [diff] [review]
patch

Crash fix for Aurora
Comment 5 Alex Keybl [:akeybl] 2012-01-09 14:54:34 PST
Comment on attachment 583388 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-10 14:14:58 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/10e5beef94a8
Comment 7 Doug Turner (:dougt) 2012-01-26 17:18:26 PST
*** Bug 721340 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.