Up-to-date scroll position lost when certain events (Flash?) propagate/are logged

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
2 months ago

People

(Reporter: stephend, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Created attachment 583394 [details]
Screenshot -- notice the scrollbar's position

Build ID: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a1) Gecko/20111220 Firefox/12.0a1

Steps to Reproduce:

1. Open a new tab
2. Tools | Web Developer | Web Console (make sure it's 
3. Load http://www.fox.com

Expected Result:

The viewport in the Web Console should always show the latest logged event/HTTP request, etc.

Actual Result:

It seems like--especially when Flash or other scripts log to the console--we lose the up-to-date scroll position; this makes web testing a little tough, as you can't just watch events scrolling by in real-time, continually, without having to adjust your scroll position.
I can't repro this bug. Can you still repro?
Blocks: 778766
Flags: needinfo?(stephen.donner)
(In reply to Mihai Sucan [:msucan] from comment #1)
> I can't repro this bug. Can you still repro?

Nope, WFM with Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130429 Firefox/23.0

I can still make the behavior happen when I click to add a filter type, but that's intended, likely, and definitely outside of the scope of this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(stephen.donner)
Resolution: --- → WORKSFORME

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.