Last Comment Bug 712594 - libffi fails to build on mingw-w64
: libffi fails to build on mingw-w64
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: js-ctypes (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla12
Assigned To: Jacek Caban
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-21 03:13 PST by Jacek Caban
Modified: 2012-08-28 14:06 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (69.85 KB, patch)
2011-12-21 03:16 PST, Jacek Caban
benjamin: review+
Details | Diff | Splinter Review
properly regen configure (11.29 KB, patch)
2012-08-19 06:46 PDT, Landry Breuil (:gaston)
mh+mozilla: review-
Details | Diff | Splinter Review

Description Jacek Caban 2011-12-21 03:13:33 PST
It fails after ABI change made for MSVC compatibility. I've fixed the problem upstream a while ago:

https://github.com/atgreen/libffi/commit/ba022c338af97cb18d9f8ed5a607fd483a61c09c

Since there are no plans to merge recent libffi anytime soon AFAIK, I will attach a backport of upstream patch.
Comment 1 Jacek Caban 2011-12-21 03:16:06 PST
Created attachment 583440 [details] [diff] [review]
fix
Comment 2 Jacek Caban 2011-12-27 01:56:12 PST
Thanks for the review.

https://hg.mozilla.org/integration/mozilla-inbound/rev/ff350b65a616
Comment 3 Jacek Caban 2011-12-27 02:13:40 PST
Backed out due to Adroid compilation failure:

https://hg.mozilla.org/integration/mozilla-inbound/rev/e88517446ab2
Comment 4 Jacek Caban 2011-12-27 02:40:38 PST
It looks like the failure was unrelated. I will run this through try again before landing.
Comment 5 Jacek Caban 2012-01-09 07:00:30 PST
Try succeeded, it looks like clobbering was needed due to configure changes. Pushed with clobbered Android builds:

https://hg.mozilla.org/integration/mozilla-inbound/rev/90a869f23e11
Comment 6 Ed Morley [:emorley] 2012-01-09 15:08:25 PST
https://hg.mozilla.org/mozilla-central/rev/90a869f23e11
Comment 7 Landry Breuil (:gaston) 2012-08-19 06:46:06 PDT
Created attachment 653177 [details] [diff] [review]
properly regen configure

Let's properly regen configure with autoconf since lines changed, see bug 670719 comment 52
Comment 8 Mike Hommey [:glandium] 2012-08-19 23:18:26 PDT
Comment on attachment 653177 [details] [diff] [review]
properly regen configure

Review of attachment 653177 [details] [diff] [review]:
-----------------------------------------------------------------

Let's do that in a separate bug
Comment 9 Landry Breuil (:gaston) 2012-08-28 14:06:36 PDT
Comment on attachment 653177 [details] [diff] [review]
properly regen configure

Discard, superseded by bug 783950

Note You need to log in before you can comment on or make changes to this bug.