APPS-Search - There are unexpected categories in "Filter Results" section.

VERIFIED FIXED in 6.3.8

Status

addons.mozilla.org Graveyard
Search
P3
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Victor Carciu, Assigned: cvan)

Tracking

ACR-0.9
6.3.8
x86
Windows XP

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 584037 [details]
Attachment

Prerequisites:
FF9

Steps to reproduce:
1.Go to APPS page in production : https://apps-preview.mozilla.org/
2.Log in with valid credentials
3.Enter the word "marble" in the search box
4.Look at "Category" under "Filter Results"

Expected results:
Under "Category" we will have only the categories listed under "Related categories" for every app , so it is impossible to have a category under "Filter Results" without any results displayed.

Actual Results:
When searching "marble" there is an emptyu "Finance" category under "Filter Results".
Please see attached screenshot.

NOTES:I was not able to reproduce the issue for another searched word.
(Reporter)

Updated

6 years ago
Blocks: 710074
No longer blocks: 690899
(Reporter)

Comment 1

6 years ago
Please note that the issue is not reproducible on staging : https://apps-preview-dev.allizom.org/
(Assignee)

Comment 2

6 years ago
Created attachment 584080 [details]
Search

Based on your same URL, searching for "marble" returns a result for each one of these listed categories.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

6 years ago
The "Dinamo bucuresti" app was created after this bug so we still have an issue. 

Anyway , there is something wrong with this "Finance" tag, since after removing the "Finance" tag from "Dinamo bucuresti" app, the app is still displayed as a result of "Finance" filter.

Please see attached screenshot.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

6 years ago
Created attachment 585380 [details]
Screenshot.
It isn't clear to me what "Related categories: Games" has to do with a finance filter.  Can you provide steps to reproduce and an expected/actual results comment?  thanks
(Assignee)

Comment 6

6 years ago
Firstly, you should *not* be using apps-preview.mozilla.org for testing. That is production. Use https://apps-preview-dev.allizom.org

So, please firstly, delete https://apps-preview.mozilla.org/en-US/apps/app/dinamo/ unless it is a legitimate app.

Anyway, back to your issue - I was unable to reproduce using the following the steps:

1) Upload an app
2) Add a tag from Edit App devhub page.
3) Ensure that tags are listed on the search page. https://apps-preview-dev.allizom.org/en-US/apps/search/?q=
4) Remove tags from Edit App devhub page.
5) Ensure that tags are NOT listed on the search page.

Can you retry this from scratch on apps-preview-dev and let me know the STR? Thanks.
(Assignee)

Comment 7

6 years ago
(In reply to Chris Van Wiemeersch [:cvan] from comment #6)
> So, please firstly, delete
> https://apps-preview.mozilla.org/en-US/apps/app/dinamo/ unless it is a
> legitimate app.

You'll want to "Disable App" from http://localhost:8000/en-US/developers/app/dinamo/status
(Assignee)

Comment 8

6 years ago
s/localhost:8000/apps-preview-dev.allizom.org/
(Reporter)

Comment 9

6 years ago
Here are some responses to the comments from above:
Comment5:The issue is that one app with one single "Games" tag is displayed when applying the "Finance" search filter, but now this issue is not reproducible anymore after log in\log out.

Comments6:As I said in Comment1, the bug is not reproducible on staging, so I cannot use staging for this bug.

Also please re-try right now on production using my original steps and the issue will be now reproducible and no results were found for "Finance" category , so this category should not be there. Please reproduce the bug exactly as described, using "marble" search, since I was not able to find another app for which the issue is reproducible.
(Assignee)

Comment 10

6 years ago
Can you still reproduce this?
(Reporter)

Comment 11

6 years ago
Yes, the issue is still reproducible. Please let me know if you need any other additional info and I will be happy to provide any help needed.

Comment 12

6 years ago
cvan and I looked at this and seems like a valid issue.

Updated

6 years ago
Assignee: nobody → cvan
(Assignee)

Updated

6 years ago
Target Milestone: --- → 6.3.7
Blocks: 718560
No longer blocks: 710074
Priority: -- → P3
(Assignee)

Comment 13

6 years ago
https://github.com/mozilla/zamboni/commit/0eb7081
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: 6.3.7 → 6.3.8
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

6 years ago
Created attachment 589514 [details]
Postfix Screenshot
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.