Last Comment Bug 713229 - configure only requires NSPR 4.8.8, but we require NSPR >= 4.9 beta 4
: configure only requires NSPR 4.8.8, but we require NSPR >= 4.9 beta 4
Status: RESOLVED FIXED
[inbound][qa-]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Mike Hommey [:glandium]
:
Mentors:
: 713122 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-23 07:52 PST by Mike Hommey [:glandium]
Modified: 2012-02-14 09:51 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Require NSPR 4.9 beta 4 or greater (2.22 KB, patch)
2011-12-23 07:54 PST, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Require NSPR 4.9 beta 4 or greater (2.23 KB, patch)
2011-12-23 08:00 PST, Mike Hommey [:glandium]
ted: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-12-23 07:52:41 PST
indexedDB code uses PR_UINT64, which is only available in NSPR 4.9 beta 4 and greater.
Comment 1 Mike Hommey [:glandium] 2011-12-23 07:54:44 PST
Created attachment 584063 [details] [diff] [review]
Require NSPR 4.9 beta 4 or greater
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-23 07:55:13 PST

*** This bug has been marked as a duplicate of bug 713122 ***
Comment 3 Mike Hommey [:glandium] 2011-12-23 08:00:07 PST
Created attachment 584064 [details] [diff] [review]
Require NSPR 4.9 beta 4 or greater
Comment 4 Mike Hommey [:glandium] 2011-12-23 08:13:32 PST
*** Bug 713122 has been marked as a duplicate of this bug. ***
Comment 5 Mike Hommey [:glandium] 2011-12-23 08:14:16 PST
There's a patch in this bug already, let's duplicate the other way around.
Comment 6 Ted Mielczarek [:ted.mielczarek] 2012-01-10 05:22:22 PST
Comment on attachment 584064 [details] [diff] [review]
Require NSPR 4.9 beta 4 or greater

Review of attachment 584064 [details] [diff] [review]:
-----------------------------------------------------------------

We should really release an NSPR 4.9 :-/
Comment 8 Ed Morley [:emorley] 2012-01-11 18:03:52 PST
https://hg.mozilla.org/mozilla-central/rev/2a6cac678c94
Comment 9 Mike Hommey [:glandium] 2012-01-25 00:51:06 PST
Comment on attachment 584064 [details] [diff] [review]
Require NSPR 4.9 beta 4 or greater

[Approval Request Comment]
The current codebase uses macros that are only present in NSPR 4.9 beta 4 and above.
This is a low risk, NPOTB patch that makes life easier for linux distributions using the --with-system-nspr flag. Making it clear if their NSPR is too old.
Comment 10 Alex Keybl [:akeybl] 2012-01-27 16:24:48 PST
Comment on attachment 584064 [details] [diff] [review]
Require NSPR 4.9 beta 4 or greater

[Triage Comment]
Low risk, NPOTB - approved for Aurora.
Comment 11 Mike Hommey [:glandium] 2012-01-30 00:22:19 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/ccbae23f3d04
Comment 12 Landry Breuil (:gaston) 2012-02-14 09:51:00 PST
Fx 11.0b1 was released depending on an unreleased nspr version, thus breaks people using system nspr. Where's the tracking bug for 4.9.0 final release ?

Note You need to log in before you can comment on or make changes to this bug.