Last Comment Bug 713391 - There should be a test to make sure Tilt is opened via the access key
: There should be a test to make sure Tilt is opened via the access key
Status: RESOLVED FIXED
[tilt][fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-24 10:39 PST by Victor Porof [:vporof][:vp]
Modified: 2012-01-28 16:08 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (3.26 KB, patch)
2011-12-24 10:41 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2011-12-24 10:39:38 PST
There were some talks about this necessity in bug 711966.
Comment 1 Victor Porof [:vporof][:vp] 2011-12-24 10:41:52 PST
Created attachment 584211 [details] [diff] [review]
v1
Comment 2 Axel Hecht [pto-Aug-30][:Pike] 2011-12-27 07:37:11 PST
We do have a dedicated set of mochitests for l10n, which are occasionally run.

Not sure if we're running other UI tests on localized builds even that often. Henrik?
Comment 3 Henrik Skupin (:whimboo) 2011-12-30 06:02:25 PST
(In reply to Axel Hecht [:Pike] from comment #2)
> We do have a dedicated set of mochitests for l10n, which are occasionally
> run.

Do we? As far as I know all mochitests exercising the en-US access keys only. Can you point me to those?

> Not sure if we're running other UI tests on localized builds even that
> often. Henrik?

No, we don't do that yet. With Mozmill we have some tests which are using access keys (even the localized ones) but those tests get run only for releases (beta, final). The coverage is also minimal. That means if localizers would like to start testing access keys, I can kindly offer my help to get this type of tests started.
Comment 4 Axel Hecht [pto-Aug-30][:Pike] 2011-12-30 06:20:55 PST
Yeah, confuzzled, I meant mozmill tests.
Comment 5 Rob Campbell [:rc] (:robcee) 2012-01-03 05:58:27 PST
guys, get a room.
Comment 6 Victor Porof [:vporof][:vp] 2012-01-13 04:30:40 PST
So is this something we can land or something we should always stay away from?
Comment 7 Mihai Sucan [:msucan] 2012-01-16 08:32:22 PST
Comment on attachment 584211 [details] [diff] [review]
v1

Review of attachment 584211 [details] [diff] [review]:
-----------------------------------------------------------------

Victor, thanks for your patch!

We do have some tests that use keyboard shortcuts to access some of the features/commands of the devtools UI. However, having a specific test for the accesskey seems a bit "overkill" - there's not much value for a test that checks only this.

Rob, what do you think?

::: browser/devtools/tilt/test/browser_tilt_04_initialization-key.js
@@ +25,5 @@
> +
> +  id = TiltUtils.getWindowId(gBrowser.selectedBrowser.contentWindow);
> +  tiltKey = Tilt.tiltButton.getAttribute("accesskey");
> +
> +  if ("nsILocalFileMac" in Ci) {

Services.appinfo.OS == "Darwin"
Comment 8 Rob Campbell [:rc] (:robcee) 2012-01-20 10:46:05 PST
https://hg.mozilla.org/integration/fx-team/rev/0c90c1267f63
Comment 9 Rob Campbell [:rc] (:robcee) 2012-01-21 07:36:51 PST
https://hg.mozilla.org/mozilla-central/rev/0c90c1267f63
Comment 10 Rob Campbell [:rc] (:robcee) 2012-01-27 07:53:44 PST
Comment on attachment 584211 [details] [diff] [review]
v1

[Approval Request Comment]
Regression caused by (bug #): New feature
User impact if declined: None, but there is developer cost.
Testing completed (on m-c, etc.): mc
Risk to taking this patch (and alternatives if risky): Negative risk. Adds a test.

Note You need to log in before you can comment on or make changes to this bug.