The default bug view has changed. See this FAQ.

All message filters disappear

RESOLVED FIXED in Thunderbird 12.0

Status

MailNews Core
Filters
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Sune Mølgaard, Assigned: Bienvenu)

Tracking

({dataloss, regression})

Trunk
Thunderbird 12.0
x86_64
All
dataloss, regression
Bug Flags:
in-testsuite ?

Thunderbird Tracking Flags

(thunderbird11 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20111225 Firefox/12.0a1 SeaMonkey/2.9a1
Build ID: 20111225003005

Steps to reproduce:

Upgrade SM to latest nightly on Dec. 24th and start it


Actual results:

No mail was filtered - turned out that all filters had disappeared from the message filter dialog. msgFilterRules.dat was empty except for version and logging ("9" and "no" respectively).
Happened again with trunk from 25th - my newly created filters were gone again...


Expected results:

Filters should have stayed in place...
(Reporter)

Updated

5 years ago
Severity: normal → blocker
Priority: -- → P1
wfm with Mozilla/5.0 (Windows NT 6.1; rv:12.0a1) Gecko/20111225 Firefox/12.0a1 SeaMonkey/2.9a1

My single message filter is still there.
Severity: blocker → critical
Priority: P1 → --
(Reporter)

Comment 2

5 years ago
Ah, yes, sorry. This is Linux.

Furthermore, I have discovered that if I add a new rule, then try to add another, the second one replaces the first...
In the same time frame 
- I've lost filters as noted in bug 713253. 
- the reporter of bp-7a462531-f732-415e-942d-665e12111225 also lost filters. his last message to me ...

"I had the profile window open when I loaded this
12.0a1. It appears that it over wrote the existing msgFilterRules.dat
or erased its contents when Thunderbird loaded. The actual file is empty
but the 'message filters' (loaded into memory?) still show in the GUI
and they continue to function as written until I close Thunderbird. Or
it crashes and closes itself. Evidently it then reads the empty file. The GUI appears to allow me to add filters but when I close the window and reopen it it is empty."
Blocks: 713253
Status: UNCONFIRMED → NEW
Component: MailNews: General → Filters
Ever confirmed: true
Keywords: dataloss, qawanted, regression, regressionwindow-wanted
Product: SeaMonkey → MailNews Core
QA Contact: mail → filters
tracking-thunderbird12: --- → ?
dgboles ...  http://harthur.github.com/mozregression/ has a -thunderbird option according to :protz

Comment 5

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> dgboles ...  http://harthur.github.com/mozregression/ has a -thunderbird
> option according to :protz


Hmm... On the webpage <http://harthur.github.com/mozregression/> it says  mozregression --app=thunderbird. Note the two dashes. That did not work.

However that fails with an error. If I knew how to add an attachment here I would so I will put it here. Please feel free to copy it here.

<http://www.box.com/s/zyniiiq2qqqt65m3zgul>
(Assignee)

Updated

5 years ago
Depends on: 707306
(Assignee)

Comment 6

5 years ago
Created attachment 584442 [details] [diff] [review]
proposed fix

this fixes filter loss, so I'd like to land it asap.
Assignee: nobody → dbienvenu
Status: NEW → ASSIGNED
Attachment #584442 - Flags: review?(neil)
No longer blocks: 713253
Keywords: qawanted, regressionwindow-wanted
OS: Linux → All

Comment 7

5 years ago
Comment on attachment 584442 [details] [diff] [review]
proposed fix

>-  NS_ENSURE_ARG(! (filterCount >= filterIndex));
>+  NS_ENSURE_TRUE(filterCount > filterIndex, NS_ERROR_INVALID_ARG);
[Would have preferred NS_ENSURE_ARG(filterCount > filterIndex);]
Attachment #584442 - Flags: review?(neil) → review+
(Assignee)

Comment 8

5 years ago
ok, switched back to NS_ENSURE_ARG - http://hg.mozilla.org/comm-central/rev/07bbbe99496f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Target Milestone: --- → Thunderbird 12.0
(Reporter)

Comment 9

5 years ago
May I, since this is file-based as opposed to something with sqlite, and since it's apparently easy to hit a code path that zeroes the file, that someone institutes a "copy to .bak, then write the new file" thing, as it's apparently done for sessionstore.json, that we've had problems with before, which I guess is the reason for making backups in-app as opposed to relying on the user to have a backup mechanism in place?

Comment 10

5 years ago
Thanks for finding the cause David :(
(Assignee)

Comment 11

5 years ago
(In reply to :aceman from comment #10)
> Thanks for finding the cause David :(

aceman, no problem.

Comment 12

5 years ago
I must be more careful next time.

Comment 13

5 years ago
The same fix is needed on Aurora channel..no
http://hg.mozilla.org/releases/comm-aurora/rev/5cca813898cc
tracking-thunderbird11: --- → ?

Comment 14

5 years ago
I guess that is the more proper flag to set.
status-thunderbird11: --- → affected

Comment 15

5 years ago
Comment on attachment 584442 [details] [diff] [review]
proposed fix

> I guess that is the more proper flag to set.
> status-thunderbird11: --- → affected
You forgot approval-comm-aurora?
Attachment #584442 - Flags: approval-comm-aurora?
(Assignee)

Comment 16

5 years ago
Comment on attachment 584442 [details] [diff] [review]
proposed fix

we should land this for aurora asap.
Attachment #584442 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 17

5 years ago
fixed on aurora - http://hg.mozilla.org/releases/comm-aurora/rev/e5d240a676e7
(Assignee)

Updated

5 years ago
status-thunderbird11: affected → fixed
tracking-thunderbird11: ? → ---
tracking-thunderbird12: ? → ---
Duplicate of this bug: 714104

Updated

5 years ago
Flags: in-testsuite?

Updated

5 years ago
Duplicate of this bug: 714296
You need to log in before you can comment on or make changes to this bug.