Closed Bug 713446 Opened 8 years ago Closed 8 years ago

White text with text-shadow in selected bottom tabs

Categories

(Toolkit :: Themes, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla12
Tracking Status
firefox11 + verified

People

(Reporter: stefanh, Assigned: stefanh)

References

Details

(Keywords: regression, Whiteboard: [qa!])

Attachments

(1 file)

Bug 681425 added Lion-specific styling to selected tabs. The styling applies also to bottom tabs, which is wrong.
Attached patch Fix stylingSplinter Review
I just added some rules to the existing selectors, no point using @media.
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
Attachment #584268 - Flags: review?(dao)
The patch in bug 681425 is in aurora, so we should fix it there too.
Given the low-risk nature of this patch, we'd likely accept once r+'d. That being said, it's not yet clear that this needs to be tracked for FF11 since it's not explicitly stated where bottom tabs are used or why the user impact would be significant.
(In reply to Alex Keybl [:akeybl] from comment #3)
> Given the low-risk nature of this patch, we'd likely accept once r+'d. That
> being said, it's not yet clear that this needs to be tracked for FF11 since
> it's not explicitly stated where bottom tabs are used or why the user impact
> would be significant.

Two examples where bottom tabs are used: Chatzilla and SeaMonkey Composer. The white text with text-shadow makes it hard to see the tab title.
(In reply to Stefan [:stefanh] (away for a while) from comment #4)
> Two examples where bottom tabs are used: Chatzilla and SeaMonkey Composer.
> The white text with text-shadow makes it hard to see the tab title.

Thanks for the background. We're now tracking this for FF11.

Dao - can you review soon so that this can land on Aurora 11 earlier in the cycle? Thanks!
Attachment #584268 - Flags: review?(dao) → review+
http://hg.mozilla.org/integration/mozilla-inbound/rev/1ea2df08454f
Whiteboard: [inbound]
Target Milestone: --- → mozilla12
https://hg.mozilla.org/mozilla-central/rev/1ea2df08454f
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Comment on attachment 584268 [details] [diff] [review]
Fix styling

[Approval Request Comment]
Regression caused by: Bug 681425
User impact if declined: Hard to see tab titles in selected bottom tabs
Testing completed (on m-c, etc.): Has baked on m-c since 2012-01-30 19:15 PST
Risk to taking this patch (and alternatives if risky): No risk at all. Patch only sets the correct style rules for bottom tabs and these type of tabs doesn't exist in Firefox.
String changes made by this patch: None
Attachment #584268 - Flags: approval-mozilla-beta?
(In reply to Stefan [:stefanh] from comment #8)
> Comment on attachment 584268 [details] [diff] [review]
> Fix styling
> 
> [Approval Request Comment]
> Regression caused by: Bug 681425
> User impact if declined: Hard to see tab titles in selected bottom tabs
> Testing completed (on m-c, etc.): Has baked on m-c since 2012-01-30 19:15 PST

19:09 to be more exact :-)
Comment on attachment 584268 [details] [diff] [review]
Fix styling

[Triage Comment]
Will only affect bottom tabs, and a low risk styling change. Approved for Beta 11.
Attachment #584268 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [qa+]
I have tried this on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0) Gecko/20100101 Firefox/11.0 beta 4

and the bottom tabs in ChatZilla and SeaMonkey Composer don't use Lion-specific styling anymore.

Considering this, setting the status to Verified Fixed on Firefox 11 beta
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.