Last Comment Bug 713767 - Permanent orange | TEST-UNEXPECTED-FAIL | test_imapHighWater.js on win32 | 6 == 11
: Permanent orange | TEST-UNEXPECTED-FAIL | test_imapHighWater.js on win32 | 6 ...
Status: RESOLVED FIXED
: intermittent-failure
Product: Thunderbird
Classification: Client Software
Component: Testing Infrastructure (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: Thunderbird 12.0
Assigned To: David :Bienvenu
:
Mentors:
Depends on: 402392
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-27 15:26 PST by David :Bienvenu
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (1.08 KB, patch)
2012-01-18 14:21 PST, David :Bienvenu
standard8: review+
Details | Diff | Splinter Review

Description David :Bienvenu 2011-12-27 15:26:58 PST
The pluggable store landing seems to have caused failure on win32 tinderbox and try server builds in test_imapHighWater.js. I can't reproduce this locally on win32 debug or release builds, or on the mac. I'm trying to diagnose it by adding more diagnostics and pushing a patch with those diagnostics to try server. If try chooser is working correctly, I should be getting just a win32 xpcshell test run.
Comment 1 Mark Banner (:standard8) 2012-01-09 04:30:27 PST
(reminder ping)
Comment 2 David :Bienvenu 2012-01-09 06:30:13 PST
I've looked into this a bit, and will look into it some more once I've finished with bug 715924
Comment 3 David :Bienvenu 2012-01-09 18:21:55 PST
It's possible that the patch in bug 704707 will fix this.
Comment 4 Serge Gautherie (:sgautherie) 2012-01-13 08:06:21 PST
http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1326417774.1326420332.18738.gz
WINNT 5.2 comm-central test xpcshell on 2012/01/12 17:22:54

Bug still there.

{
TEST-UNEXPECTED-FAIL | e:/buildbot/comm-central-win32-opt-unittest-xpcshell/build/xpcshell/tests/mailnews/imap/test/unit/test_imapHighWater.js | 6 == 11 - See following stack:
...
JS frame :: e:/buildbot/comm-central-win32-opt-unittest-xpcshell/build/xpcshell/tests/mailnews/imap/test/unit/test_imapHighWater.js :: doMoves :: line 171
JS frame :: ../../../resources/asyncTestUtils.js :: _async_driver :: line 155
JS frame :: e:\buildbot\comm-central-win32-opt-unittest-xpcshell\build\xpcshell\head.js :: <TOP_LEVEL> :: line 429

TEST-INFO | (xpcshell/head.js) | exiting test
*******************************************
Generator explosion!
Unhappiness at: undefined:undefined
Because: 2147500036

TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | TypeError: ex.stack is undefined - See following stack:
JS frame :: ../../../resources/asyncTestUtils.js :: _async_driver :: line 166
JS frame :: e:\buildbot\comm-central-win32-opt-unittest-xpcshell\build\xpcshell\head.js :: anonymous :: line 429
...
}
Comment 5 David :Bienvenu 2012-01-17 15:22:08 PST
I spent three days reviving my windows xp machine and build environment, investigated and worked around bug 718541, but this test still passes for me on my windows machines w/ a release build.
Comment 6 David :Bienvenu 2012-01-18 14:21:37 PST
Created attachment 589643 [details] [diff] [review]
proposed fix

I'll push this to try, once I have a fix for the offlineStoreLocking test as well, but I think this might fix it.
Comment 7 Mark Banner (:standard8) 2012-01-19 04:34:52 PST
I've pushed this to try server:

http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=c3994808caec
Comment 8 Mark Banner (:standard8) 2012-01-19 10:25:10 PST
Comment on attachment 589643 [details] [diff] [review]
proposed fix

Looks good. Thanks.
Comment 9 David :Bienvenu 2012-01-19 11:52:56 PST
fixed on trunk.

Note You need to log in before you can comment on or make changes to this bug.