change Pref container dialog to a Control Panel container

VERIFIED WONTFIX

Status

SeaMonkey
General
--
enhancement
VERIFIED WONTFIX
17 years ago
12 years ago

People

(Reporter: Simon Lucy, Assigned: Matthew Paul Thomas)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: se-radar, URL)

(Reporter)

Description

17 years ago
The current Preference dialogs have a lot of shortcomings mostly from trying to
force all preferences to fit a single size.  The tree navigation of preferences
is also difficult for users to penetrate or understand.

The referenced URL is a rough outline of a Control Panel approach...  comments
welcome.

Comment 1

17 years ago
OK confirming RFE as I've not seen this suggested elsewhere.
The User Interface: Design Feedback seems like the most appropriate place for
this because this isn't a bug with the existing preferences panel but a request
for a total revamp of this.

BTW if you haven't already post this proposal to the appropriate newsgroups:
netscape.public.mozilla.ui should be appropriate and also .prefs
Status: UNCONFIRMED → NEW
Component: Preferences → User Interface: Design Feedback
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
Updated the document to include a sample RDF definition and a description of the
UI in XUL terms.

I announced this in prefs, ui and wishlist at the time but I'll freshen that.
Assignee: matt → mpt
simon, the link appears dead --d'you have a more recent url? and/or, could you
attach the outline to this bug? thx!
(Assignee)

Comment 4

16 years ago
Simon, ping? It would be interesting to see what you're talking about.
(Reporter)

Comment 5

16 years ago
I've updated the link to the original document.
(Reporter)

Updated

16 years ago
(Reporter)

Comment 6

16 years ago
Updated the document to include a mockup of the Control Panel Window.  
Whiteboard: se-radar
marlon/samir, what d'you think?
Depends on: 114521
Hardware: PC → All
Summary: [RFE]To change Pref container dialog to a Control Panel container → change Pref container dialog to a Control Panel container
(Assignee)

Comment 8

16 years ago
Simon, I still don't see anything at that address ... It's an empty HTML doc.
(Reporter)

Comment 9

16 years ago
It was there when I published it.  It looks like it got lost when I republished
the site.  Its back there now, thanks for telling me.
(Reporter)

Updated

16 years ago

Comment 10

16 years ago
isn't this too much of a "windows" look?
non-win32 users would probably object to such a design...
(Reporter)

Comment 11

16 years ago
Is this a criticism of how it looks or what it achieves?
Also check KDE's control panel and Gnome's.  

Comment 12

16 years ago
well. i don't know. i don't use either gnome or kde, but it *looks* like it's
windows style. The name "Control Panel" is an especially blatant reminder of
Windows Control Panel.
(Reporter)

Comment 13

16 years ago
Yes it is blatant, I don't think there's anything particularly wrong in that.
You could lose the left hand box which gives more detail about the selected icon
on the right but its a tiny thing.  

What about its intent?  That preferences be taken out of the artificial and from
the user's point of view difficult interface that we have hat present.

Comment 14

16 years ago
What about the users that have been used to the interfaces for many years?
It was the way that Netscape did it and the way Mozilla/Netscape6 then
does it.

You should mark this OS -> Windows.
Last thing Linux users want to see is a Control Panel.
> Last thing Linux users want to see is a Control Panel.

You mean that the last thing _you_ want to see is a Control Panel.

The approach actually makes sense to me.  Instead of a dialog with a tree that I
have to read and then select and then change prefs, we could have a window that
lets you open pref panels by clicking on labeled icons.

The most obvious benefit is being able to have two pref panels open at the same
time.

Comment 16

16 years ago
ehh. whatever. i'm removing myself from cc. pointless arguing.
i knew linux couldn't last long before people started turning it into windows.
(Assignee)

Comment 17

16 years ago
There are a lot of good ideas here, including flattening the category 
hierarchy, and getting rid of the Advanced category, and using the filesystem 
as a UI for accessing the preferences.

However, Mozilla-the-browser -- or even Mozilla-the-Internet-suite -- is not an 
island, or an operating environment (unlike Windows, Mac OS, or OEOne 
HomeBase), and its popularity will tend to be inversely proportional to the 
degree to which it tries to be a system unto itself. By having an entire set of 
control panels for its own preferences, I think Mozilla risks looking arrogant 
and overly complex. In addition, it would encourage over-complexity in 
individual preference categories (we've got a whole window of our own to play 
with, let's put subcategory tabs/groupboxes/listboxes/trees in it!), and make 
tasks like switching between preference categories unnecessarily slow (two or 
three clicks instead of one).

For different applications -- WordPad, Gnumeric, Composer, Navigator -- there 
should indeed be separate prefs windows, as those programs have little to do 
with each other. And where settings can obviously be located in a particular 
place in the UI, they should go there rather than being dumped in the 
preferences. (For example, address book prefs should be accessed only from the 
Address Book menus, and the UI for customizing mail labels should be accessed 
only from the Label submenu.) But to have multiple independent windows for
non-locatable settings in the same application, I think, is overkill.
(Reporter)

Comment 18

16 years ago
I'm not sure that risking looking arrogant is all that bad a thing :-).  The
other side of the coin is though, how to flatten the categories and make
preferences accessible unless its this kind of UI.  Whether generalised for all
Mozilla apps or separated by application.

I agree completely that separate applications should have their own preference
management, but that can be seen as a different layer.  Some preferences cross
Mozilla app boundaries, security, proxy settings, font bases and so on.  Those
kind of preferences should be navigable vertically through the environment as
well as horizontally at the application layer.

From my point of view, Mozilla as browser is much less interesting than Mozilla
as cross platform development and I'll admit that colours my intent.  However, I
still think its a viable model for handling preferences.  

Comment 19

16 years ago
BTW, the KDE control panel has a tree navigation, and has panels about different
application in it. Also, the panels themselves have tab navigation between
different aspects sometimes.

They have a big difference to our prefs windows though: each panel can be called
outside the main control-panel (without the tree pointing to all other available
panels), therefore every panel has it's own "Apply" and "Cancel" buttons and if
you change panels, you always have to "Apply" first - you'll get an alert if you
changed something and didn't "Apply".
They also seem to have a possibility to call a window with only a certain subset
of all panels (which are interesting for the calling application), with showing
the icons of those on the right handed side of the window instead of the whole
tree view.

And don't forget that also newer Windows versions (like e.g. XP) split the
control panel into main categories, providing them in a tree view from Explorer.
(Assignee)

Comment 20

16 years ago
> The other side of the coin is though, how to flatten the categories and make
> preferences accessible unless its this kind of UI.

That is relatively easy. First, have one preferences dialog for each program.
Second, chuck out silly panels such as those for Mousewheel, Downloads, Software
Installation, and Validation. I've been maintaining a Navigator Preferences spec
which is flattened into only 13 panels (mainly for fun, since I doubt anyone
will ever volunteer to implement it), and I dare say any competent interface
designer could do the same.

> Some preferences cross Mozilla app boundaries, security, proxy settings, font
> bases and so on.  Those kind of preferences should be navigable vertically
> through the environment as well as horizontally at the application layer.

And they are, through the Internet control panels on both Windows and Mac OS. We
have various bugs on lack of support for the settings in those control panels.
And once equivalent control panels establish themselves in Linux environments,
lack of support for those control panels will be bugs as well.

> Mozilla as browser is much less interesting than Mozilla as cross platform
> development and I'll admit that colours my intent.

How useful Mozilla-the-platform is for developing cross-platform apps has
exactly nothing to do with Mozilla-the-browser's preferences interface.

Wontfix for the reasons given in comment 17.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 21

16 years ago
>> Some preferences cross Mozilla app boundaries, security, proxy settings, font
>> bases and so on.  Those kind of preferences should be navigable vertically
>> through the environment as well as horizontally at the application layer.

>And they are, through the Internet control panels on both Windows and Mac OS. We
>have various bugs on lack of support for the settings in those control panels.
>And once equivalent control panels establish themselves in Linux environments,
>lack of support for those control panels will be bugs as well.

Well no they aren't, which is the whole point.  There are scads of preferences
which either have no UI at all to set them or have multiple views.  Just
collapsing the categories isn't enough.  

I really don't like it being set to WONTFIX because its an RFE not a bug.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Assignee)

Comment 22

16 years ago
Yes, I would have marked it INVALID (because the requested behavior would not 
be an enhancement), but people get grouchy when I do that, claiming that RFEs 
can't possibly be invalid. So, I mark bad RFE ideas as WONTFIX instead. WONTFIX.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WONTFIX
mass-verifying Wontfix bugs.

mail filter string for bugspam: Tursiopstruncatus
Status: RESOLVED → VERIFIED

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.