[traceback] App Submission broken for any non-en-US locale

VERIFIED FIXED in 6.3.6

Status

addons.mozilla.org Graveyard
Developer Pages
P1
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: cvan, Assigned: cvan)

Tracking

unspecified
6.3.6

Details

(URL)

(Assignee)

Description

6 years ago
Traceback (most recent call last):

  File "/data/www/apps-preview.mozilla.org/zamboni/vendor/src/django/django=
/core/handlers/base.py", line 111, in get_response
    response =3D callback(request, *callback_args, **callback_kwargs)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/amo/decorators.py",=
 line 102, in wrapper
    return f(*args, **kw)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/amo/decorators.py",=
 line 94, in wrapper
    return f(*args, **kw)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/decorators.p=
y", line 60, in wrapper
    return f(request, *args, webapp=3Dshow_webapp, **kwargs)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/addons/decorators.p=
y", line 29, in wrapper
    return f(request, addon, *args, **kw)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/amo/decorators.py",=
 line 28, in wrapper
    return func(request, *args, **kw)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/decorators.p=
y", line 42, in wrapper
    return fun()

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/decorators.p=
y", line 26, in <lambda>
    *args, **kw)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/views.py", l=
ine 1335, in wrapper
    return f(request, *args, **kw)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/views.py", l=
ine 1487, in submit_describe
    'step': step, 'webapp': addon.is_webapp()})

  File "/data/www/apps-preview.mozilla.org/zamboni/vendor/src/jingo/jingo/_=
_init__.py", line 80, in render
    rendered =3D render_to_string(request, template, context)

  File "/data/www/apps-preview.mozilla.org/zamboni/vendor/src/jingo/jingo/_=
_init__.py", line 98, in render_to_string
    return template.render(**get_context())

  File "/usr/lib64/python2.6/site-packages/jinja2/environment.py", line 891=
, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/templates/de=
vhub/addons/submit/describe.html", line 2, in top-level template code
    {% extends "devhub/addons/submit/base.html" %}

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/templates/de=
vhub/addons/submit/base.html", line 6, in top-level template code
    {% set title =3D _('Submit a New Add-on') %}

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/templates/de=
vhub/base.html", line 51, in top-level template code
    {% set hide_mobile_link=3DTrue %}

  File "/data/www/apps-preview.mozilla.org/zamboni/templates/base.html", li=
ne 108, in top-level template code
    {% block main_content %}

  File "/data/www/apps-preview.mozilla.org/zamboni/templates/base.html", li=
ne 111, in block "main_content"
    {% block content %}{% endblock %}

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/templates/de=
vhub/addons/submit/base.html", line 23, in block "content"
    {% block primary %}{% endblock %}

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/templates/de=
vhub/addons/submit/describe.html", line 51, in block "primary"
    {{ select_cats(amo.MAX_CATEGORIES, form, webapp) }}

  File "/data/www/apps-preview.mozilla.org/zamboni/apps/devhub/templates/de=
vhub/includes/macros.html", line 70, in template
    max)|f(max)|safe }}

  File "/data/www/apps-preview.mozilla.org/zamboni/vendor/src/jingo/jingo/h=
elpers.py", line 25, in f
    return string.format(*args, **kwargs)

IndexError: tuple index out of range
(Assignee)

Comment 1

6 years ago
https://github.com/mozilla/zamboni/commit/585b7f8

I cannot reproduce this issue locally. I have no idea how the locales got wonked up, but the localized strings for this `ngettext` call ("Select <b>up to {0}</b> categories for this app:") appear to be missing the `{0}`, ultimately making the string interpolation impossible.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 2

6 years ago
In bug 710552, we turned off locale detection. So accessing the submission page from any locale, just redirects to en-US.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.