Last Comment Bug 714083 - Update app.support.baseURL to point to support.mozilla.org
: Update app.support.baseURL to point to support.mozilla.org
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-29 09:19 PST by Ricky Rosario [:rrosario, :r1cky]
Modified: 2012-01-13 02:55 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v0.1 (1.24 KB, patch)
2011-12-29 11:09 PST, Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
gavin.sharp: review+
Details | Diff | Splinter Review

Description Ricky Rosario [:rrosario, :r1cky] 2011-12-29 09:19:23 PST
SUMO just finished moving over to support.mozilla.org. Links to support.mozilla.com will redirect over, but the links in Firefox (Help->Firefox Help, for example) should be updated to avoid the 301 redirect.
Comment 1 James Socol [:jsocol, :james] 2011-12-29 09:21:33 PST
This is just updating the app.support.baseURL preference to s/.com/.org/.

zpao, can you help us get this to the right place?
Comment 2 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-12-29 11:09:41 PST
Created attachment 584799 [details] [diff] [review]
Patch v0.1

Are there any other changes that we should make to this pref while we're here? It seems that regardless of version & platform I'm just getting redirected to su.m.o/LOCALE/home?as=u. It looks like mobile uses sumo/mobile as it's base url.

Relatedly, make sure you file a bug for mobile as well if you haven't already.
Comment 3 James Socol [:jsocol, :james] 2011-12-29 11:18:01 PST
The locale, platform, and version bits can be used to direct specific Firefoxes to specific articles for any particular topic. I think it's used in a couple of places, but not with the generic F1/Firefox>Help links.

I'll go file a mobile bug.
Comment 4 James Socol [:jsocol, :james] 2011-12-29 11:25:34 PST
(In reply to James Socol [:jsocol, :james] from comment #3)
> I'll go file a mobile bug.

Filed bug 714123.
Comment 5 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-01-11 11:19:59 PST
https://hg.mozilla.org/integration/fx-team/rev/a1388e9f3679
Comment 6 Tim Taubert [:ttaubert] 2012-01-13 02:55:49 PST
https://hg.mozilla.org/mozilla-central/rev/a1388e9f3679

Note You need to log in before you can comment on or make changes to this bug.