Closed Bug 714437 Opened 8 years ago Closed 8 years ago

[ro] In message composition, Alt Gr + <letter> keyboard shortcuts for Romanian characters like ă open Help page

Categories

(Mozilla Localizations :: ro / Romanian, defect, major)

All
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tct, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [ro])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111220101134

Steps to reproduce:

0. Open Thunderbird 9.0/9.0.1 from releases.mozilla.org in Fedora GNU/Linux 64bit.
1. Opened window to write a new message (Ctrl + N).
2. Started to write Romanian letters using Alt Gr + letter (a -> ă, s -> ș, t -> ț)


Actual results:

Every press on Alt Gr opens Launch Application dialog.

This happens only in the Message Compose window, not in the rest of Thunderbird windows.


Expected results:

Write ă, ș, ț in the Message Compose window.
Should be added under bug 713979 ?
Thanks for the tip, I wrote a comment on traking bug 713979. I hope this bug will be added to the tracker.
It seems Alt Gr is set to open help/support page: http://support.mozillamessaging.com. The Launch Application dialog showed up because I hadn't set a default browser to open links in.

Please confirm.
Ludo, can you CC a Romanian localizer or anyone else who can confirm this bug on a Romanian System that uses the AltGr+letter shortcut system for Romanian characters?

Tiberiu, thanks for filing this bug report and suggesting it for the tracker. I've added your bug to the tracker, but I'm not sure if it belongs there, because I don't fully understand your bug and it seems to be an edge case.

1) Can you please translate all the text of the "Launch application" dialogue shown on attachment 585129 [details] (the title, message, list items, buttons etc.).
2) Is "Launch application" a Thunderbird dialogue, an OS dialogue, or a dialogue of a helper application?
3) Is AltGr + letter shortcut system part of Thunderbird, the OS, or another helper application?
4) Can you give an example in which other UI part of TB AltGr + Letter produces the correct Romanian characters?
5) In the compose window of TB, were AltGr + letter combinations for Romanian letters ever working in a previous version of TB? If yes, what is the most recent version where this was still working?
^^ Ludo, can you CC a Romanian localizer or anyone else who can confirm this bug on a Romanian System that uses the AltGr+letter shortcut system for Romanian characters?
(Sorry for double post, I had a midair-collision with myself... ;-))
Summary: Alt Gr used for Romanian letters opens Application Launch → In message composition, Alt Gr + <letter> keyboard shortcuts for Romanian characters like ă opens "Launch Application" Dialogue
(In reply to Thomas D. from comment #4)
> Ludo, can you CC a Romanian localizer or anyone else who can confirm this
> bug on a Romanian System that uses the AltGr+letter shortcut system for
> Romanian characters?

I asked myself on the mailing list:

http://groups.google.com/group/mozilla-ro/browse_thread/thread/9276fd34aab45107

> Tiberiu, thanks for filing this bug report and suggesting it for the
> tracker. I've added your bug to the tracker, but I'm not sure if it belongs
> there, because I don't fully understand your bug and it seems to be an edge
> case.

Let me rephrase: Alt Gr in Message Compose window opens Help (http://support.mozillamessaging.com) in browser.

I probably wouldn't have noticed this if I was not using Alt Gr for special Romanian letters.

> 1) Can you please translate all the text of the "Launch application"
> dialogue shown on attachment 585129 [details] (the title, message, list
> items, buttons etc.).

It's the same with this one on Windows:

http://support.thehunter.com/attachments/token/0tjvjts0ypyvmq0/?name=Firefox-launch-application.png

> 2) Is "Launch application" a Thunderbird dialogue, an OS dialogue, or a
> dialogue of a helper application?

A Thunderbird dialogue. I remember Firefox has the same dialogue. Anyway, the above screenshot proves it's not an OS dialogue.

> 3) Is AltGr + letter shortcut system part of Thunderbird, the OS, or another
> helper application?

Alt Gr + a = ă in all the system (including Thunderbird main window, but in Composer window - there Alt Gr is Help).

> 4) Can you give an example in which other UI part of TB AltGr + Letter
> produces the correct Romanian characters?

Search box in Thunderbird main window.

> 5) In the compose window of TB, were AltGr + letter combinations for
> Romanian letters ever working in a previous version of TB? If yes, what is
> the most recent version where this was still working?

This is the first time I encounter the problem, after upgrading from 8.* to 9.* series.

Anyone using Thunderbird 9.0 on GNU/Linux should be able to confirm this by pressing Alt Gr in Compose Message window.

All other Thunderbird UI parts are working correctly and all other applications in my system.
Talking with Raul, tt seems F1 (Help) is not working at all in my Thunderbird 9. And AltGr does what F1 is supposed to do.

https://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts#os=linux&browser=tb9
Ludo, do you have a GNU/Linux machine for testing with TB9? What happens if you press AltGr in message composition?
Confirmed in openSUSE 11.4, KDE 4.7.4. for ROMANIAN locale ONLY and Keyboard layout Romanian (default, standard and winkey).

1. Pressing ALTGR key  opened help page: http://support.mozillamessaging.com/en-US/home#os=linux&browser=tb9

2. CTRL+SHIFT+K - not working

Perhaps is accesskey problem? Or broken import from Narro?

Alex, please check last import.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Tibi, window Launch Application is opened because you don't have set default browser .
Also, romanian character ă ș ț â î are shown in Message Compose window.
Blocks: 632886
Severity: normal → major
Hardware: x86_64 → All
Summary: In message composition, Alt Gr + <letter> keyboard shortcuts for Romanian characters like ă opens "Launch Application" Dialogue → [ro] In message composition, Alt Gr + <letter> keyboard shortcuts for Romanian characters like ă open Help page
Whiteboard: [ro]
Target Milestone: --- → Thunderbird 10.0
Same problem in Tb 10 (Beta).
Also with us-USA keyboard - ALTGR + A opened menu Ajutor (letter A is underlined).
Perhaps keys is interchanged: CTL - ALTGR. ?
(In reply to Raul Malea from comment #10)
> Tibi, window Launch Application is opened because you don't have set default
> browser .
> Also, romanian character ă ș ț â î are shown in Message Compose window.

Yes, I know -- if you tick the check box to remember the browser to use, you can write Romanian special letters, but when you get back to Firefox you find dozens of support.mozillamessaging.com tabs.

The problem is that AltGr does what F1 is supposed to do (open Help/Support). While F1 doesn't work.

But this seems to be a problem only in the Romanian localized version of Thunderbird.
I can reproduce it as well so I'll check the localization.
Status: NEW → ASSIGNED
Still can't find the problem, reverted to the previous translation and no luck, so any help is appreciated.
Well, I guess it's somehow related to Romanian localization. Can other Thunderbird users reproduce the bug with a different localization?

Please note I am not using the add-on (I guess the translation and keyboard shortcuts came from Fedora distribution).
Is this resolved?  Ubuntu is still getting reports with Thunderbird 11.
Looks like this is a localisation issue, so moving it across.
Component: Message Compose Window → ro / Romanian
Product: Thunderbird → Mozilla Localizations
QA Contact: message-compose → romanian.ro
Target Milestone: Thunderbird 10.0 → ---
Version: 9 → unspecified
I can reproduce it in 11.0.1, so I'll look into it.
Duplicate of this bug: 752189
Fixed in Aurora, http://hg.mozilla.org/releases/l10n/mozilla-aurora/ro/rev/f9378a9d3dba 
Will need to bring the translations up to date before doing a signoff.

However, this looks like a general bug, putting a letter instead of a code (VK_F1) in the openHelp.commandkey screws things up in an unexpected way.
Signed off in the dashboard with Aurora. Not sure if it makes sense to commit this in beta as well.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.