Last Comment Bug 714697 - rm lingering remains of JSCLASS_CONSTRUCT_PROTOTYPE
: rm lingering remains of JSCLASS_CONSTRUCT_PROTOTYPE
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla12
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-02 18:59 PST by Luke Wagner [:luke]
Modified: 2012-01-04 04:51 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rm (35.37 KB, patch)
2012-01-02 18:59 PST, Luke Wagner [:luke]
jwalden+bmo: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-01-02 18:59:31 PST
Created attachment 585346 [details] [diff] [review]
rm

Bug 702507 removed only half the mess.

 12 files changed, 129 insertions(+), 294 deletions(-)

The patch would be smaller, but I kept JS_ConstructObject(WithArguments) (it's not used in mozilla but it may still be of some use to embeddings) and moved InvokeConstructor to be next to InvokeConstructorKernel.  Lastly I s/JSFunction::isConstructor/JSFunction::isNativeConstructor/ since the former name confused me every time.
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2012-01-03 07:49:11 PST
Comment on attachment 585346 [details] [diff] [review]
rm

Review of attachment 585346 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jsapi.cpp
@@ +3435,5 @@
> +                                uintN argc, jsval *argv)
> +{
> +    AssertNoGC(cx);
> +    CHECK_REQUEST(cx);
> +    assertSameCompartment(cx, JSValueArray(argv, argc));

No same-compartment assert for parent?
Comment 2 Luke Wagner [:luke] 2012-01-03 08:26:48 PST
(In reply to Jeff Walden (remove +bmo to email) from comment #1)
> No same-compartment assert for parent?

Oops, I temporarily removed 'parent' and forgot to put this back.
Comment 4 Marco Bonardo [::mak] 2012-01-04 04:51:32 PST
https://hg.mozilla.org/mozilla-central/rev/a917bd8e3f8e

Note You need to log in before you can comment on or make changes to this bug.