Closed Bug 714747 Opened 8 years ago Closed 8 years ago

Port |Bug 655678 - Precompile startup cache for xulrunner| and |Bug 639462 - "make install" doesn't install the SDK| to SeaMonkey

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.9

People

(Reporter: sgautherie, Assigned: InvisibleSmiley)

References

Details

Attachments

(1 file)

See Thunderbird bug 674352.
Flags: in-testsuite-
Blocks: FF2SM
Not taking yet since I dared to try and fix two bugs in one go...
Attachment #585389 - Flags: review?(bugspam.Callek)
Attachment #585389 - Flags: review?(kairo)
Assignee: nobody → jh
Attachment #585389 - Flags: review?(kairo)
Attachment #585389 - Flags: review?(bugspam.Callek)
Attachment #585389 - Flags: review+
Status: NEW → ASSIGNED
Duplicate of this bug: 640154
Summary: Port |Bug 655678 - Precompile startup cache for xulrunner| to SeaMonkey → Port |Bug 655678 - Precompile startup cache for xulrunner| and |Bug 639462 - "make install" doesn't install the SDK| to SeaMonkey
Comment on attachment 585389 [details] [diff] [review]
patch for bug 640154 and this one [Checkin: Comment 2]

http://hg.mozilla.org/comm-central/rev/f05c98a3a3a2
Attachment #585389 - Attachment description: patch for bug 640154 and this one → patch for bug 640154 and this one [Checkin: Comment 2]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.9
(In reply to Serge Gautherie (:sgautherie) from bug 640154 comment #0)
> We should check whether anything else from the latter bug (still) needs to
> be ported too.

I checked bug 639462 changeset:

config/autoconf.mk.in:
c-c is already sync'ed as that change happened in 2007 in CVS repository.
I assume the same about the other shared-then-duplicated files.

browser/build.mk:
its change was ported in
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/suite/build.mk&rev=1.7
I am loath to check the 5 other browser/ files.
We will just assume there was only that installer/Makefile.in change missing.
No longer blocks: FF2SM
Severity: enhancement → normal
Whiteboard: [good first bug]
Depends on: 639462
Depends on: 389673
V.Fixed, wrt startup cache part:
omni.ja now contains 'jsloader/resource/*' files :-)
You need to log in before you can comment on or make changes to this bug.