Last Comment Bug 714775 - IonMonkey: Assertion failure: [infer failure] Missing type pushed 0: <0x1812200>
: IonMonkey: Assertion failure: [infer failure] Missing type pushed 0: <0x1812200>
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2012-01-03 06:57 PST by Jan de Mooij [:jandem]
Modified: 2012-01-04 10:47 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (959 bytes, patch)
2012-01-03 07:03 PST, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-01-03 06:57:15 PST
check-crypto-md5.js and check-crypto-sha1.js fail with --ion -n.
Comment 1 Jan de Mooij [:jandem] 2012-01-03 07:03:46 PST
Created attachment 585400 [details] [diff] [review]
Patch

The problem was that the resume point after an inlined call referred to the callee instead of the return value. TI complained since we ended up with an object (the callee) instead of undefined (the expected return type).

The md5 and sha1 tests pass with this patch + the patch in bug 714676.
Comment 2 David Anderson [:dvander] 2012-01-03 11:23:43 PST
Comment on attachment 585400 [details] [diff] [review]
Patch

Review of attachment 585400 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch.
Comment 3 David Anderson [:dvander] 2012-01-03 11:44:00 PST
http://hg.mozilla.org/projects/ionmonkey/rev/284cc80e914b

Note You need to log in before you can comment on or make changes to this bug.