Closed Bug 715090 Opened 10 years ago Closed 10 years ago

Hang if attempt to change mailbox during initialization while showing the new mail toaster popup

Categories

(Thunderbird :: General, defect)

11 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 711787

People

(Reporter: robertc, Unassigned)

Details

(Keywords: hang, Whiteboard: [closeme 2012-02-02])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

I opened up Earlybird.  I have three IMAP mailboxes configured, one of which has several filters for various mailing lists I'm on.  One of the mailboxes other than the one selected by default has new mail so I click on it, at this point the application hangs.


Actual results:

CPU use does not appear to be high but the application is unresponsive.  The new mail toaster popup is still visible, and the status bar shows that messages are still being processed in the mailbox which has loads of rules.


Expected results:

The application should not have hung.  If there's some way to get more detailed information please let me know and I'll try it.  I can replicate this nearly every morning.
cpu zero?
if so, might be fixed in tomorrow's *Daily* build - but not aurora's
Severity: normal → critical
Keywords: hang
Rob?

(In reply to Wayne Mery (:wsmwk) from comment #1)
> cpu zero?
> if so, might be fixed in tomorrow's *Daily* build - but not aurora's

bienvenu, standard8 - might you know what bug might have fixed this, and whether it landed in aurora? I don't remember which bug I was thinking of when I wrote this.
Whiteboard: [closeme 2012-02-02]
It's still happening for me in Aurora.  If I happen to leave my mouse pointer over any of my IMAP mail folders (so that, normally, a highlight would show on hover) then the application hangs.  I've not had time to backup my whole profile and upgrade to Nightly to see if it's fixed there.
To be clear: If I happen to leave my mouse pointer over any of my IMAP mail folders *while Thunderbird is starting up*.
are you using SSL/TLS? If so, it might be 711787, though I don't think incoming mail would get processed in that case.
The connection security on the server is set to STARTTLS.  Would hovering the mouse over a folder trigger the routine mentioned in 711787 to be called?  Would the update to Aurora today or yesterday have included that fix?  I can see it's been checked in on Tuesday, but I'm not familiar with the details of the release process.
(In reply to Rob Crowther from comment #6)
> The connection security on the server is set to STARTTLS.  Would hovering
> the mouse over a folder trigger the routine mentioned in 711787 to be
> called? 
possibly, yes. It would trigger an attempt to get the preview text for the new messages in the folder, which might have to run an imap url.

> Would the update to Aurora today or yesterday have included that
> fix? 
Yes.
I've tried a few times today and haven't managed to trigger the issue, so it does look like the same problem as 711787.
ok, thx.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 711787
You need to log in before you can comment on or make changes to this bug.