Mail shows body as source, nothing in header pane (after SpamAssassin, clamAV?)

RESOLVED DUPLICATE of bug 713611

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 713611
6 years ago
6 years ago

People

(Reporter: Sune Mølgaard, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 585733 [details]
fail1.X.eml

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120104 Firefox/12.0a1 SeaMonkey/2.9a1
Build ID: 20120104003016

Steps to reproduce:

Get mails


Actual results:

Quite a few mails have begun showing source as body and no headers in the header pane, which I haven't really seen before. Some mails are plain text, others are HTML and one is base64-encoded (I'll attach the latter two).

However, not all mails are affected, and I can't find a commonality, except that my mails is run through SpamAssassin (and clamAV by my host) - I don't know if they mangle something...

Note: The base64-encoded mail doesn't show correctly in 2.8a2 or 2.7b2 either...


Expected results:

Mail should display normally
(Reporter)

Comment 1

6 years ago
Created attachment 585735 [details]
Another email (email addresses replaced by X@X.X)
(Reporter)

Comment 2

6 years ago
BTW, this seems similar to bug 604620, but happens with POP. Perhaps MailNews Core, Networking in general, not IMAP specifically?

Also, the notification mail from this bugzilla about the bug being reported shows normally, but the one about attachment fail2.X.eml shows incorrectly (!), so it doesn't seem 100% reproducible.

I have only begun seeing this very recently (after 2.9a1)...
(Reporter)

Comment 3

6 years ago
Created attachment 585738 [details]
Notfication email about fail2.X.eml attachment (email addresses replaced by X@X.X)

Comment 4

6 years ago
CC WADA-san
Depends on: 604620
Attachment #585733 - Attachment mime type: application/octet-stream → text/plain
Attachment #585735 - Attachment mime type: application/octet-stream → text/plain
Attachment #585738 - Attachment mime type: application/octet-stream → text/plain
(In reply to Sune Mølgaard from comment #0)
> Build ID: 20120104003016
> Quite a few mails have begun showing source as body (snip)
> but happens with POP

Same as screen shot attached to bug 714182 ( attachment 584859 [details] )?
If so, perhaps dup of bug 713611.

By the way, duplicated headers are seen in attached .eml files.
> Return-Path: <X@X.X>
> Return-Path: <X@X.X>
> X-Original-To: X@X.X
> X-Original-To: X@X.X
> Message-ID: <20120104132649.5040.X@X.X.dk>
> Message-ID: <20120104132649.5040.X@X.X.dk>
> Delivered-To: X@X.X
> Delivered-To: X@X.X
> From: X@X.X
> From: X@X.X
> To: X@X.X
> To: X@X.X
> Reply-To: X@X.X.dk
> Reply-To: X@X.X.dk

Why?
If actually downloaded data from POP3 server, is your server properly configured?
(Reporter)

Comment 6

6 years ago
Similar to screenshot - just Seamonkey instead. Repairing folder works as reported there (and the time frame fits), so very likely a dup of bug 713611 as you said.

Duplicate headers a probably a result of me being to quick and rusty with sed that I ran the .eml files through - sorry :-$

Server is a web host no probs before, and as stated, the time frame fits.

Thank you for answering,

Sune
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713611
You need to log in before you can comment on or make changes to this bug.