Mouse click + drag causing Tilt to Translate instead of Rotate on First Open

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Inspector
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: rc, Assigned: vporof)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tilt])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR:

1. Open Tilt on a page.
2. Click with mouse (trackpad) and drag around

Expected results:

Page is rotated.

Actual:

Sometimes the page translates instead of rotates.

Not sure why this is happening but it seems to only happen the first time Tilt is opened. Subsequent drag events work as expected.
(Assignee)

Updated

6 years ago
Whiteboard: [tilt]
(Assignee)

Comment 1

5 years ago
I really can't reproduce this :(
(Assignee)

Comment 2

5 years ago
I may have found a reason for this: Tilt is opened using Ctr+W (or Ctr+M before bug 711966). Ctrl+Click changes left click to right click. Right click + drag = translate, while left click + drag = rotate.

So whenever you do Ctrl+Click + drag you get translation. Is this the problem?
(Reporter)

Comment 3

5 years ago
Hm! Maybe. It usually happens after I've opened Tilt and start dragging. There could be something to the right-click to translate function. All I know is that it's confusing when it happens. I'll watch my fingers the next time I see it.
(Assignee)

Comment 4

5 years ago
I could disable all events for a split second when you open Tilt. This would allow the initial animation to finish (and also even avoid any of that weird znear/zfar clipping if you have fast fingers). How about that?
(Reporter)

Comment 5

5 years ago
Can we do this and increase the speed of the intro animation? We want the UI to be responsive within 50ms.
(Assignee)

Comment 6

5 years ago
It's a plan.
(Assignee)

Comment 7

5 years ago
Created attachment 589134 [details] [diff] [review]
v1
(Assignee)

Updated

5 years ago
Assignee: nobody → vporof
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Depends on: 718425
(Assignee)

Updated

5 years ago
Blocks: 718973
(Reporter)

Comment 8

5 years ago
did you want review on this patch? No request present and it's a blocker for bug 718973.
(Assignee)

Comment 9

5 years ago
(In reply to Rob Campbell [:rc] (robcee) from comment #8)
> did you want review on this patch? No request present and it's a blocker for
> bug 718973.

Yes please :)
(Assignee)

Updated

5 years ago
Attachment #589134 - Flags: review?(rcampbell)
(Reporter)

Updated

5 years ago
Attachment #589134 - Flags: review?(rcampbell) → review+
(Reporter)

Comment 10

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/85fbc84de818
Whiteboard: [tilt] → [tilt][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/85fbc84de818
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [tilt][fixed-in-fx-team] → [tilt]
Target Milestone: --- → Firefox 12
(Reporter)

Comment 12

5 years ago
Comment on attachment 589134 [details] [diff] [review]
v1

[Approval Request Comment]
Regression caused by (bug #): New Feature
User impact if declined: Occasional accidental tranlation
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): Pretty minimal changes.
Attachment #589134 - Flags: approval-mozilla-aurora?
(Reporter)

Updated

5 years ago
tracking-firefox11: --- → ?
(Reporter)

Updated

5 years ago
Target Milestone: Firefox 12 → ---
(Reporter)

Updated

5 years ago
tracking-firefox11: ? → ---
(Reporter)

Updated

5 years ago
Attachment #589134 - Flags: approval-mozilla-aurora?
You need to log in before you can comment on or make changes to this bug.