Last Comment Bug 715292 - URL bar left and right edges should be slightly straighter
: URL bar left and right edges should be slightly straighter
Status: VERIFIED FIXED
: polish
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P4 normal (vote)
: Firefox 14
Assigned To: Sriram Ramasubramanian [:sriram]
:
Mentors:
Depends on: 712687
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-04 12:37 PST by Ian Barlow (:ibarlow)
Modified: 2016-07-29 14:21 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
11+


Attachments
screenshot (Android 2.3.6) (84.83 KB, image/png)
2012-02-24 23:39 PST, Peter Retzer (:pretzer)
no flags Details
Patch (1.23 KB, patch)
2012-03-14 13:17 PDT, Sriram Ramasubramanian [:sriram]
mark.finkle: review+
Details | Diff | Splinter Review

Description Ian Barlow (:ibarlow) 2012-01-04 12:37:21 PST
The URLBar should look like a heavily rounded rectangle, but not a completely rounded pill shape. See http://cl.ly/0v3R0F0Z3R2f0D362y0u for reference.  

This problem seems to vary from device to device. On a Galaxy Nexus in Portrait it's ok, in landscape it becomes pill shaped. On GB phones it's almost always too round. Could this be an issue with 9-patching?
Comment 1 Sriram Ramasubramanian [:sriram] 2012-02-24 16:25:44 PST
Works for me.
Comment 2 Peter Retzer (:pretzer) 2012-02-24 23:39:26 PST
Created attachment 600627 [details]
screenshot (Android 2.3.6)

Still visible for me (Galaxy S2, Android 2.3.6), see screenshot.
Like comment #0 says, this seems to be different between devices/Android versions.
Please REOPEN.
Comment 3 Cristian Nicolae (:xti) 2012-02-28 05:23:00 PST
(In reply to pretzer from comment #2)
> Created attachment 600627 [details]
> screenshot (Android 2.3.6)
> 
> Still visible for me (Galaxy S2, Android 2.3.6), see screenshot.
> Like comment #0 says, this seems to be different between devices/Android
> versions.
> Please REOPEN.

I see this on my Galaxy S2 (Android 2.3.4). Reopening bug
Comment 4 Sriram Ramasubramanian [:sriram] 2012-03-14 13:17:53 PDT
Created attachment 605917 [details] [diff] [review]
Patch

Accidentally found the reason while I was working on ICS clipboard bar. This should fix the issue on pre-honeycomb devices.
Comment 5 Sriram Ramasubramanian [:sriram] 2012-03-15 12:31:33 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/4d2544852d32
Comment 6 Marco Bonardo [::mak] 2012-03-16 06:17:31 PDT
https://hg.mozilla.org/mozilla-central/rev/4d2544852d32
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2012-03-24 09:08:06 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/42c5f1679156
Comment 8 Paul Feher 2012-03-27 06:18:56 PDT
Verified/fixed on:

Aurora Fennec 13.0a2 (2012-03-27)
Nightly Fennec 14.0a1 (2012-03-27)
Device: Samsung Nexus S
OS: Android 2.3.6

Note You need to log in before you can comment on or make changes to this bug.