Open Bug 715399 Opened 8 years ago Updated 4 years ago

Port |Bug 218142 - Add "Show Image" to context menu of not-successfully-loaded images| to SeaMonkey

Categories

(SeaMonkey :: UI Design, defect)

defect
Not set

Tracking

(Not tracked)

REOPENED
Future

People

(Reporter: sgautherie, Assigned: sgautherie)

References

()

Details

(Whiteboard: [Landing depends on bug 436483 fix first])

Attachments

(1 file)

SeaMonkey already has "Show Image" feature,
but is missing the "not-successfully-loaded" part:
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/browser/base/content/nsContextMenu.js&rev=1.35

In case that situation would have been intentional, we should just add a comment instead.
Comment on attachment 585954 [details] [diff] [review]
(Av1) Port bug 218142 ('onCompletedImage')

PS: 'showImage()' is now 'viewMedia()'. SM code is +/- different than FF code, and I'm not touching that part...
Blocks: 715410
I don't think we should do this at least until Bug 436483 is fixed.
> Blocks: 715410
I don't see any direct dependencies?
No longer blocks: 715410
Depends on: 436483
(In reply to Philip Chee from comment #3)
> > Blocks: 715410
> I don't see any direct dependencies?

(Only that I had planned to work on bug 715410 after this one.)
Whiteboard: [Wait for bug 436483 first]
Target Milestone: seamonkey2.9 → Future
Comment on attachment 585954 [details] [diff] [review]
(Av1) Port bug 218142 ('onCompletedImage')

Well, SeaMonkey's fix preceded Firefox; I don't know why they wanted to limit it to incomplete images only but apparently it makes sense to.
Attachment #585954 - Flags: review?(neil) → review+
Neil, do you agree that I check this in right away,
or should I wait for bug 436483 as Philip suggested?
(In reply to Serge Gautherie from comment #6)
> should I wait for bug 436483 as Philip suggested?
That's a good idea; we don't want to port broken behaviour.
No longer depends on: 713173
Whiteboard: [Wait for bug 436483 first] → [Landing depends on bug 436483 fix first]
This is either WORKSFORME or a DUP of Bug 47475
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 47475
(In reply to Philip Chee from comment #8)
> This is either WORKSFORME or a DUP of Bug 47475

[Mozilla/5.0 (Windows NT 6.0; rv:29.0) Gecko/20100101 Firefox/29.0 SeaMonkey/2.26.1]

I don't think so (unless I am missing something):
Bug 47475 would rather be the initial SeaMonkey bug Neil was thinking of in his comment 5.
Current behavior (in SM browser) is still unconditional.
Mxr search confirms that there was "no change".
Status: RESOLVED → REOPENED
Depends on: 47475
Resolution: DUPLICATE → ---
(In reply to neil@parkwaycc.co.uk from comment #7)
> (In reply to Serge Gautherie from comment #6)
> > should I wait for bug 436483 as Philip suggested?
> That's a good idea; we don't want to port broken behaviour.

Whiteboard: "Landing depends on bug 436483 fix first"
Bug 436483 (in "Core / Networking:HTTP") is now WONTFIX, see bug 436483 comment #7.
Does this mean that this bug is WONTFIX too, or shall we implement broken behaviour anyway, or will some other solution have to be found?
Flags: needinfo?(neil)
(In reply to Tony Mechelynck from comment #10)
> Bug 436483 (in "Core / Networking:HTTP") is now WONTFIX.
> Does this mean that this bug is WONTFIX too, or shall we implement broken
> behaviour anyway, or will some other solution have to be found?

I don't think implementing broken behaviour is a good idea, since I've occasionally reloaded a partially loaded image, and if we take this patch then we wouldn't be able to do that, as due to the WONTFIX we wouldn't have an accurate way of detecting that, and taking the patch as-is would lead to a false negative in this case.
Flags: needinfo?(neil)
You need to log in before you can comment on or make changes to this bug.