Last Comment Bug 715810 - Bug 679476 causes crash in [@ mime_parse_stream_complete]
: Bug 679476 causes crash in [@ mime_parse_stream_complete]
Status: RESOLVED FIXED
: crash, regression, topcrash
Product: MailNews Core
Classification: Components
Component: MIME (show other bugs)
: Trunk
: x86 Windows NT
: -- critical (vote)
: Thunderbird 12.0
Assigned To: David :Bienvenu
:
:
Mentors:
Depends on:
Blocks: 679476
  Show dependency treegraph
 
Reported: 2012-01-05 21:44 PST by Makoto Kato [:m_kato]
Modified: 2012-01-22 19:45 PST (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
affected
+
fixed
fixed


Attachments
bulletproof fix (766 bytes, patch)
2012-01-10 09:43 PST, David :Bienvenu
standard8: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2012-01-05 21:44:34 PST
mdd->messageBody is null


This bug was filed from the Socorro interface and is 
report bp-56635412-cbe7-436d-be2c-73e532120103 .
============================================================= 
0 	xul.dll 	mime_parse_stream_complete 	mailnews/mime/src/mimedrft.cpp:1610
1 	xul.dll 	nsStreamConverter::OnStopRequest 	mailnews/mime/src/nsStreamConverter.cpp:1090
2 	xul.dll 	nsStreamListenerTee::OnStopRequest 	netwerk/base/src/nsStreamListenerTee.cpp:71
3 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
4 	xul.dll 	nsProxyObjectCallInfo::Run 	xpcom/proxy/src/nsProxyEvent.cpp:182
5 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
6 	xul.dll 	NS_ProcessNextEvent_P 	objdir-tb/mozilla/xpcom/build/nsThreadUtils.cpp:245
7 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
8 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
9 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
10 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
11 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
12 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:261
13 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:228
14 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3557
15 	thunderbird.exe 	do_main 	mail/app/nsMailApp.cpp:143
16 	thunderbird.exe 	NS_internal_main 	mail/app/nsMailApp.cpp:226
17 	thunderbird.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:107
18 	thunderbird.exe 	__tmainCRTStartup 	crtexe.c:594
19 	kernel32.dll 	BaseProcessStart
Comment 1 Wayne Mery (:wsmwk, NI for questions) 2012-01-06 03:28:36 PST
same as bug 564701?
Comment 2 Makoto Kato [:m_kato] 2012-01-06 03:47:32 PST
(In reply to Wayne Mery (:wsmwk) from comment #1)
> same as bug 564701?

No.  When filing bug 564701, bug 679476 isn't landed.
Comment 3 Makoto Kato [:m_kato] 2012-01-06 03:49:07 PST
This crash appears from 9.0 and top 3 crash into 9.0.1 now.
Comment 4 Mark Banner (:standard8, limited time in Dec) 2012-01-06 04:38:36 PST
Do we have any idea what can cause this?
Comment 5 Mark Banner (:standard8, limited time in Dec) 2012-01-06 04:38:57 PST
(In reply to Mark Banner (:standard8) from comment #4)
> Do we have any idea what can cause this?

or rather, trigger it.
Comment 6 Wayne Mery (:wsmwk, NI for questions) 2012-01-06 06:47:46 PST
(In reply to Makoto Kato from comment #2)
> (In reply to Wayne Mery (:wsmwk) from comment #1)
> > same as bug 564701?
> 
> No.  When filing bug 564701, bug 679476 isn't landed.

then I understand you to say this is a regression from bug 679476
Comment 7 David :Bienvenu 2012-01-06 07:17:46 PST
Any ideas about steps to reproduce the issue? We can bullet-proof it, of course, but we won't know if there are issues downstream.
Comment 8 David :Bienvenu 2012-01-10 09:43:40 PST
Created attachment 587353 [details] [diff] [review]
bulletproof fix

since this is a top crash, we should protect against it.
Comment 9 Makoto Kato [:m_kato] 2012-01-10 17:03:24 PST
(In reply to David :Bienvenu from comment #7)
> Any ideas about steps to reproduce the issue? We can bullet-proof it, of
> course, but we won't know if there are issues downstream.

I don't know.  I think that it depends on mail header and body.
Comment 10 Mark Banner (:standard8, limited time in Dec) 2012-01-11 07:36:45 PST
Comment on attachment 587353 [details] [diff] [review]
bulletproof fix

r=me, lets get this in on branches as well.
Comment 11 David :Bienvenu 2012-01-11 07:44:50 PST
fixed on trunk - http://hg.mozilla.org/comm-central/rev/6c76c5640293 - if standard8 doesn't beat me to it, I'll try to transplant this to the branches later when I'm on my mac.
Comment 12 Mark Banner (:standard8, limited time in Dec) 2012-01-11 11:01:42 PST
Checked into branches:

http://hg.mozilla.org/releases/comm-aurora/rev/19f2edf25ef9
http://hg.mozilla.org/releases/comm-beta/rev/fabf6e73f3b6

Note You need to log in before you can comment on or make changes to this bug.