Last Comment Bug 716233 - Use Roboto as default on ICS
: Use Roboto as default on ICS
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: mozilla12
Assigned To: Makoto Kato [:m_kato]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-07 07:16 PST by Makoto Kato [:m_kato]
Modified: 2012-03-12 15:36 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (3.48 KB, patch)
2012-01-07 07:17 PST, Makoto Kato [:m_kato]
jd.bugzilla: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2012-01-07 07:16:56 PST
- ICS has new font "Roboto" as default.  Also, Galaxy Nexus has no Droid Sans.  Our prefs.js defines only "Droid Sans" for san-serif, so Fennec doesn't use Roboto.
- ICS has new font MotoyaLMaru and MotoyaLCedar for Japanese.  We should add it for font.*.ja.
Comment 1 Makoto Kato [:m_kato] 2012-01-07 07:17:40 PST
Created attachment 586668 [details] [diff] [review]
fix
Comment 3 Ed Morley [:emorley] 2012-01-31 08:50:09 PST
https://hg.mozilla.org/mozilla-central/rev/eac4b032f258
Comment 4 Jonathan Kew (:jfkthame) 2012-03-12 15:31:38 PDT
It looks like this didn't make it into the m-c -> aurora merge for mozilla12, so it's currently headed for mozilla13. In view of bug 721719, which is seriously aggravated by the lack of Droid Sans on ICS devices (and so we fall back to an unexpected and broken font), I think we should consider taking this for 12.
Comment 5 Jonathan Kew (:jfkthame) 2012-03-12 15:36:09 PDT
Argh - sorry for the bugspam - please ignore comment 4, this _did_ make it into mozilla12.

Note You need to log in before you can comment on or make changes to this bug.