Last Comment Bug 721719 - Font issue: Two characters painted at same position (ICS)
: Font issue: Two characters painted at same position (ICS)
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla12
Assigned To: Jonathan Kew (:jfkthame)
:
: Milan Sreckovic [:milan]
Mentors:
: 712752 728295 730235 (view as bug list)
Depends on: 736726
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-27 03:43 PST by Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
Modified: 2012-12-21 19:48 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
fixed
fixed
11+


Attachments
font issue 10^-18 (1.74 KB, image/png)
2012-01-27 03:43 PST, Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
no flags Details
font issue 10^18 (1.12 KB, image/png)
2012-01-27 03:43 PST, Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
no flags Details
font issue ae (724 bytes, image/png)
2012-01-27 03:44 PST, Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
no flags Details
patch, ignore the GSUB table in Roboto (5.59 KB, patch)
2012-02-25 11:03 PST, Jonathan Kew (:jfkthame)
no flags Details | Diff | Splinter Review
Roboto-Regular.ttf (72.91 KB, text/plain)
2012-02-25 13:45 PST, Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
no flags Details
patch 2, ignore GDEF table in Lohit Devanagari (1.39 KB, patch)
2012-03-12 15:05 PDT, Jonathan Kew (:jfkthame)
jd.bugzilla: review-
Details | Diff | Splinter Review
patch 3, try Roboto as well as Droid Sans for fallback in gfxFT2Fonts (983 bytes, patch)
2012-03-12 15:11 PDT, Jonathan Kew (:jfkthame)
jd.bugzilla: review+
Details | Diff | Splinter Review
patch 4, add some more ICS fonts to the prefs (1.96 KB, patch)
2012-03-12 15:39 PDT, Jonathan Kew (:jfkthame)
jd.bugzilla: review+
Details | Diff | Splinter Review
list of android sdk fonts vs. galaxy nexus fonts (5.78 KB, text/plain)
2012-03-15 19:57 PDT, John Daggett (:jtd)
no flags Details
patch 1v2, ignore GSUB table in Roboto on Android only (6.17 KB, patch)
2012-03-16 02:56 PDT, Jonathan Kew (:jfkthame)
no flags Details | Diff | Splinter Review
patch 1v3, ignore GSUB table in Roboto on Android only, corrected (6.27 KB, patch)
2012-03-16 03:08 PDT, Jonathan Kew (:jfkthame)
jd.bugzilla: review+
Details | Diff | Splinter Review
patch for aurora & beta (10.02 KB, patch)
2012-03-19 02:40 PDT, Jonathan Kew (:jfkthame)
jfkthame: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-01-27 03:43:04 PST
Created attachment 592093 [details]
font issue 10^-18

Fennec Native 2012-01-26, Android 4.0.3 stock, Google Nexus S

There seem to be some font issues with Android 4.0 builds (ICS, Ice Cream Sandwich): Sometimes, two characters are painted at same position.

Steps to reproduce:

Example 1:
1. On Facebook in a comment box, type 10^-18 or 10^18
Actual result: The latter behind ^ is painted at the same position like the ^
Additional information: After typing the ^, the cursor is left to it.

Example 2:
1. On Facebook or addons.mozilla.org, type 'a' and 'e'.
Acutal result: It will look like the French letter combining these two letters:
U+00E6	æ	c3 a6	LATIN SMALL LETTER AE
Additional information: Typing 'o' and 'e' works normal despite the existence of a French letter consisting of 'o' and 'e'.

Furthermore, sometimes the typed text is not shown at all (seems to happen if the textarea is larger than the viewport).
Comment 1 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-01-27 03:43:50 PST
Created attachment 592095 [details]
font issue 10^18
Comment 2 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-01-27 03:44:25 PST
Created attachment 592096 [details]
font issue ae
Comment 3 Aaron Train [:aaronmt] 2012-01-30 10:14:15 PST
I can reproduce (01/30 Nightly).
Comment 4 Jonathan Kew (:jfkthame) 2012-02-02 11:39:36 PST
What font is being used here on ICS - is this Roboto, or a version of Droid Sans, or....? (It's hard to be sure from just a few low-res glyphs.) Could you attach a copy of the actual .ttf file involved, copied from the device?
Comment 5 Aaron Train [:aaronmt] 2012-02-02 11:57:10 PST
I'm not sure which font is used. Is there a way to check via ADB? I've uploaded all fonts from my Galaxy Nexus [1], and Nexus S where I see the same thing.

[1] http://people.mozilla.org/~atrain/mobile/tests/ics-fonts/
Comment 6 Aaron Train [:aaronmt] 2012-02-17 14:52:49 PST
*** Bug 728295 has been marked as a duplicate of this bug. ***
Comment 7 Aaron Train [:aaronmt] 2012-02-24 05:52:05 PST
*** Bug 730235 has been marked as a duplicate of this bug. ***
Comment 8 Aaron Train [:aaronmt] 2012-02-24 05:52:35 PST
ping?
Comment 9 Jonathan Kew (:jfkthame) 2012-02-25 05:27:35 PST
The "ae" (æ) problem, at least, is an error (or misfeature) in the Roboto font, at least in the version you posted from your Nexus device; the 'liga' feature (common ligatures, enabled by default in Firefox) has the following lookup:

      <Lookup index="1">
        <LookupType value="4"/>
        <LookupFlag value="0"/>
        <!-- SubTableCount=1 -->
        <LigatureSubst index="0" Format="1">
          <LigatureSet glyph="a">
            <Ligature components="e" glyph="ae"/>
          </LigatureSet>
          <LigatureSet glyph="f">
            <Ligature components="i" glyph="fi"/>
          </LigatureSet>
        </LigatureSubst>
      </Lookup>

This implements exactly two ligatures: "fi", which is reasonable (though it's usually best if accompanied by "fl", "fj", "ff" and a few more), and "ae", which is just dumb. An "ae" -> "æ" ligature, if implemented at all, should be part of an _optional_ feature that is NOT expected to be applied universally.

I'd suggest reporting this as a bug against the Roboto font and/or the ICS distribution.

Not sure what's up with the 10^18 and 10^-18 oddity yet....
Comment 10 Jonathan Kew (:jfkthame) 2012-02-25 09:41:39 PST
The "ae" problem in Roboto is easily reproduced on desktop as well, just by installing and using the Roboto font.

Aaron, could you confirm whether you also see the "10^18" problem that Archaeopteryx showed? I'm wondering whether you have the same font versions, as I haven't found an explanation for that one in the fonts I've looked at from your directory.

While we're here, I'll note that there is something very fishy going on with the font files you provided: if you examine the DroidSans.ttf and DroidSansBold.ttf files (e.g. just hex-dump them, or run them through "strings"), you'll find that they actually contain copies of the Roboto Regular and Bold fonts. It's possible that Google (or someone) decided to do this so that applications that load the fonts directly by filename will "automagically" get Roboto in place of Droid Sans, but IMHO it is totally bogus.
Comment 11 Jonathan Kew (:jfkthame) 2012-02-25 11:03:20 PST
Created attachment 600693 [details] [diff] [review]
patch, ignore the GSUB table in Roboto

This makes me really sad, but I don't see any good alternative.

This patch fixes the "ae" issue in Roboto, by disabling the GSUB table. I'm not sure about the 10^18 issue yet; I suspect that's different, as the font in that screenshot looks more like Droid Sans than Roboto to me, but I have not been able to reproduce the problem with the version I have.
Comment 12 Jonathan Kew (:jfkthame) 2012-02-25 11:15:10 PST
Hmm, on looking again, it doesn't look much like Droid Sans either.
Comment 13 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-02-25 13:00:06 PST
I had seen the problem on facebook.com in comment boxes and comments themselves.

Another site for reproducing:
1. Open http://tagesschau.de
2. Type into the box on the left with "Suchbegriff" "10^" - the "^" will be at the same position like "0".
Comment 14 Jonathan Kew (:jfkthame) 2012-02-25 13:27:21 PST
It's still not clear to me what font is actually being used on your device when this happens. Is there any possibility you could post the font files from the phone where you see this behavior?
Comment 15 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-02-25 13:45:21 PST
Created attachment 600716 [details]
Roboto-Regular.ttf

DroidSans.ttf is a symlink to Roboto-Regular.ttf, I attach that one.
Comment 16 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-02-25 13:57:51 PST
If you need all fonts, tell me if I should attach them as a zip bundle.

Here the list with SHA-1 checksums:

D2F4473A433EF98E61444CAFA244771C19C8DA28 AndroidClock.ttf
D2F4473A433EF98E61444CAFA244771C19C8DA28 AndroidClock_Highlight.ttf
D2F4473A433EF98E61444CAFA244771C19C8DA28 AndroidClock_Solid.ttf
8B0F7A0A6F6E7FFC3F49B5507A40729EB7EFE3C2 Clockopia.ttf
DA7F477D090424368109A7FFACAA86C8213D5055 DroidNaskh-Regular.ttf
674ACC70C26ED425BE5BC741E56F509A8A11689B DroidSans.ttf
942FAB6918C0DC9BF59F62AB15E3FD38736BBE8D DroidSansArmenian.ttf
685FDC8A18DA8995E8C5FF3D1FF8C6C5EBE45D4B DroidSans-Bold.ttf
885BBCF16DAD157EBBA7F94B50F94E37270E21D5 DroidSansEthiopic-Regular.ttf
5D5585DB75D4AA85BA71FB433422C2A756C0C3D0 DroidSansFallback.ttf
A86CBE08308D46177195AE18B19A67A2FC071863 DroidSansGeorgian.ttf
6E71C7637CD5854E62729F5D79805888BB244653 DroidSansHebrew-Bold.ttf
C7E45C379F0A0A3BA85C69EAEE6B62E26FFB81A8 DroidSansHebrew-Regular.ttf
133FB6CF26EA073B456FB557B94CE8C46143B117 DroidSansMono.ttf
F746CFD066FAC2F25F89AA7CE9B2CA9975085E98 DroidSansThai.ttf
294FA99CEAF6077AB633B5A7C7DB761E2F76CF8C DroidSerif-Bold.ttf
B7F2D37C3A062BE671774FF52F4FD95CBEF813CE DroidSerif-BoldItalic.ttf
BDD8AAD5E6AC546D11E7378BDFABEAC7CCBDADFC DroidSerif-Italic.ttf
805C5F975E02F488FA1DD1DD0D44ED4F93B0FAB4 DroidSerif-Regular.ttf
2FC9039DF6D536338932D0D265377F3A3927752F Lohit-Bengali.ttf
E33AD9ACE1C6C767E2395F06C22039887F2C9F40 Lohit-Devanagari.ttf
2DEE5EFC39B5C8D57533591D35C92A1A787A22EA Lohit-Tamil.ttf
685FDC8A18DA8995E8C5FF3D1FF8C6C5EBE45D4B Roboto-Bold.ttf
A247D79724BF63E4DA834F587D6FE0D0A28CB9C3 Roboto-BoldItalic.ttf
0FD0EC4834E1226801260809C47D9A26A4825E9A Roboto-Italic.ttf
674ACC70C26ED425BE5BC741E56F509A8A11689B Roboto-Regular.ttf
Comment 17 Jonathan Kew (:jfkthame) 2012-02-26 01:30:03 PST
(In reply to Archaeopteryx [:aryx] from comment #15)
> Created attachment 600716 [details]
> Roboto-Regular.ttf
> 
> DroidSans.ttf is a symlink to Roboto-Regular.ttf, I attach that one.

Thanks. Aha - that explains why the "DroidSans.ttf" that Aaron posted turned out to contain the Roboto font! (See comment 10.)

Your Roboto-Regular is identical to his; probably all the fonts are the same. So the patch here will definitely fix "ae"; I still don't understand what's causing the 10^18 problem. I'll dig around some more.
Comment 18 Jonathan Kew (:jfkthame) 2012-03-08 05:48:57 PST
(In reply to Jonathan Kew (:jfkthame) from comment #11)
> Created attachment 600693 [details] [diff] [review]
> patch, ignore the GSUB table in Roboto

jdaggett, review ping?
Comment 19 John Daggett (:jtd) 2012-03-11 21:35:23 PDT
(In reply to Jonathan Kew (:jfkthame) from comment #17)
> Your Roboto-Regular is identical to his; probably all the fonts are the
> same. So the patch here will definitely fix "ae"; I still don't understand
> what's causing the 10^18 problem. I'll dig around some more.

The patch seems fine but I'd like to be sure we understand the nature of the 10^18 problem before taking this.
Comment 20 Jonathan Kew (:jfkthame) 2012-03-12 14:03:54 PDT
I finally figured out what's happening with 10^18. The key point to note here is that the glyphs shown in the screenshot are *not* Roboto, nor one of the Droid faces; they look more like Helvetica than anything else I can think of. But there doesn't appear to be any Helvetica or Helvetica-clone present among the ICS fonts.

Well, on looking through all those fonts more closely, I realized that the Lohit-Bengali and Lohit-Devanagari fonts actually have "Helvetica-clone" glyphs for the ASCII digits. And sure enough - disassembling Lohit-Devanagari shows that it (but not Lohit-Bengali) has a crucial error in its GDEF table.... the ASCII circumflex glyph is incorrectly marked as being "class 3", i.e. a non-spacing mark.

So the problem arises because of a series of unfortunate events. The CSS on facebook doesn't explicitly request any of the available ICS fonts, so we end up using a generic (sans-serif, presumably). But the default sans-serif font in Firefox/Android is configured as Droid Sans. That's fine on earlier Android releases, which include this font. However, ICS does NOT ship with Droid Sans - despite what you see in Aaron's font directory (comment 5). The file "DroidSans.ttf" that appear there is in fact a second copy of Roboto (apparently it's a symlink on the device, see comment 15).

Therefore, when we go to render this text, we don't find a specific font in the CSS stack; and we don't find a font via preferences either. So we hit the generic system fallback, and pick the first font we find that supports the required characters - which happens to be Lohit Devanagari. And Lohit Devanagari is broken. :(

We could work around the Lohit Devanagari problem by ignoring its GDEF (like we do for Times Italic), but in addition I think we need to add Roboto to the font prefs, so that we'll avoid falling back to the (unexpected) Indic font for text like this.
Comment 21 Jonathan Kew (:jfkthame) 2012-03-12 15:05:53 PDT
Created attachment 605149 [details] [diff] [review]
patch 2, ignore GDEF table in Lohit Devanagari

Yuck.
Comment 22 Jonathan Kew (:jfkthame) 2012-03-12 15:11:10 PDT
Created attachment 605154 [details] [diff] [review]
patch 3, try Roboto as well as Droid Sans for fallback in gfxFT2Fonts

In gfxFT2Fonts.cpp, there's a hardcoded fallback to Droid Sans if we didn't find any fonts in the font group. As ICS doesn't include this font, we should add Roboto as an alternative there.

(Actually, we should re-examine the whole font configuration and fallback mess on Android. But that's a bigger undertaking, and we should fix this now for FF13 and perhaps even FF12.)
Comment 23 Jonathan Kew (:jfkthame) 2012-03-12 15:29:14 PDT
Ah, looks like Roboto has been added to some of the font prefs for android in bug 716233. I'd expect that to help with the 10^18 issue here, as it'll make it much less likely we'll end up using the Lohit font. However, we should still work around the Lohit problem, I suppose.

Also, there are a few more cases where we currently list only Droid Sans in the prefs, and should add an ICS-provided font - either Roboto or one of the script-specific variants of Droid Sans - for better compatibility.
Comment 24 Jonathan Kew (:jfkthame) 2012-03-12 15:39:15 PDT
Created attachment 605169 [details] [diff] [review]
patch 4, add some more ICS fonts to the prefs
Comment 25 Jonathan Kew (:jfkthame) 2012-03-13 04:49:21 PDT
FTR, I filed a ticket (https://fedorahosted.org/lohit/ticket/6) about the Lohit GDEF error.
Comment 26 Jonathan Kew (:jfkthame) 2012-03-13 05:25:33 PDT
And filed the Roboto ligature bug as http://code.google.com/p/android/issues/detail?id=26809.
Comment 27 John Daggett (:jtd) 2012-03-15 19:57:31 PDT
Created attachment 606436 [details]
list of android sdk fonts vs. galaxy nexus fonts

Galaxy Nexus appears to be shipping with Android 4.0 (ver14) fonts with several omissions and changes.  The Lohit-xxx fonts are GalaxyNexus-specific additions.
Comment 28 Jonathan Kew (:jfkthame) 2012-03-16 01:51:04 PDT
Interesting.

Regardless, I think we need to disable the Roboto GSUB table, given the problem of the æ ligature. And we should include Roboto alongside Droid Sans in the places it's currently missing.

The Lohit-specific patch is less urgent, once prefs are updated so that we're unlikely to hit that font accidentally, though with Indic shaping moving forward we're going to want the ability to use those fonts before too long...
Comment 29 John Daggett (:jtd) 2012-03-16 02:01:00 PDT
Comment on attachment 600693 [details] [diff] [review]
patch, ignore the GSUB table in Roboto

>      void AddFontEntry(nsRefPtr<gfxFontEntry> aFontEntry) {
> -        // bug 589682 - set the IgnoreGDEF flag on entries for Italic faces
> -        // of Times New Roman, because of buggy table in those fonts
> -        if (aFontEntry->IsItalic() && !aFontEntry->IsUserFont() &&
> -            Name().EqualsLiteral("Times New Roman"))
> -        {
> -            aFontEntry->mIgnoreGDEF = true;
> +        // This totally sucks, but if we don't hack around these broken fonts
> +        // we get really bad text rendering, which we can't inflict on users. :(
> +        // If we accumulate a few more examples of this stuff, it'll be time
> +        // to create some prefs for the list of fonts where we need to ignore
> +        // layout tables. Sigh.
> +        if (!aFontEntry->IsUserFont()) {
> +            // bug 589682 - set the IgnoreGDEF flag on entries for Italic faces
> +            // of Times New Roman, because of buggy table in those fonts
> +            if (aFontEntry->IsItalic() &&
> +                Name().EqualsLiteral("Times New Roman")) {
> +                aFontEntry->mIgnoreGDEF = true;
> +            }
> +            // bug 721719 - set the IgnoreGSUB flag on entries for Roboto
> +            // because of unwanted on-by-default "ae" ligature
> +            else if (Name().EqualsLiteral("Roboto")) {
> +                aFontEntry->mIgnoreGSUB = true;
> +            }
>          }
>          mAvailableFonts.AppendElement(aFontEntry);
>          aFontEntry->SetFamily(this);
>      }

I agree this sucks but I don't think this is the right place for a hack
like this. If this is a necessary evil on android, then let's put this
logic in the gfxFT2FontList code, not in code that all fonts on all
platforms use.
Comment 30 John Daggett (:jtd) 2012-03-16 02:03:46 PDT
Comment on attachment 605169 [details] [diff] [review]
patch 4, add some more ICS fonts to the prefs

> +pref("font.name.sans-serif.he", "Droid Sans Hebrew, Droid Sans");

I think you mean font.name-list.sans-serif.he here.
Comment 31 John Daggett (:jtd) 2012-03-16 02:11:14 PDT
Comment on attachment 605149 [details] [diff] [review]
patch 2, ignore GDEF table in Lohit Devanagari

>              // bug 721719 - set the IgnoreGSUB flag on entries for Roboto
> -            // because of unwanted on-by-default "ae" ligature
> +            // because of unwanted on-by-default "ae" ligature...
>              else if (Name().EqualsLiteral("Roboto")) {
>                  aFontEntry->mIgnoreGSUB = true;
>              }
> +            // ...and the IgnoreGDEF on Lohit Devanagari because it marks
> +            // the ASCII circumflex as being a non-spacing mark glyph
> +            else if (Name().EqualsLiteral("Lohit Devanagari")) {
> +                aFontEntry->mIgnoreGDEF = true;
> +            }

Yikes.  I really don't think this is a good idea.  I think the other
patches should prevent text falling back to this font, I don't think we
need to workaround this font bug this way.  This isn't a common font,
it's not included in the default set of Android fonts and it's not a
font typically intended for Latin text.
Comment 32 Jonathan Kew (:jfkthame) 2012-03-16 02:56:30 PDT
Created attachment 606509 [details] [diff] [review]
patch 1v2, ignore GSUB table in Roboto on Android only

OK, here's a version that limits the Roboto hack to Android only. That's a reasonable approach, I guess - although it's possible for desktop users to install Roboto, they're not as likely to have the buggy version. And if they do encounter it, they can more easily install an updated font, whereas for most mobile device users, they'll remain stuck with whatever shipped on their device.
Comment 33 Jonathan Kew (:jfkthame) 2012-03-16 02:58:15 PDT
(In reply to John Daggett (:jtd) from comment #30)
> Comment on attachment 605169 [details] [diff] [review]
> patch 4, add some more ICS fonts to the prefs
> 
> > +pref("font.name.sans-serif.he", "Droid Sans Hebrew, Droid Sans");
> 
> I think you mean font.name-list.sans-serif.he here.

Indeed, thanks!
Comment 34 Jonathan Kew (:jfkthame) 2012-03-16 03:08:52 PDT
Created attachment 606512 [details] [diff] [review]
patch 1v3, ignore GSUB table in Roboto on Android only, corrected

Small (but crucial) correction: we need to compare the family name to "roboto" (lowercase) here, because we've applied ToLowerCase to the name when turning it into a font-list key.
Comment 35 Jonathan Kew (:jfkthame) 2012-03-17 02:44:35 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a09b2ba98ad
https://hg.mozilla.org/integration/mozilla-inbound/rev/12795e663337
https://hg.mozilla.org/integration/mozilla-inbound/rev/6a1461e64c4c

Archaeopteryx, Aaron: once these patches have merged to mozilla-central and appear in Nightly builds (in a day or two), please check that the problem is actually resolved on your devices - thanks!
Comment 37 Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2012-03-18 09:02:12 PDT
Thank you for resolving the issue.

Verified fixed with Fennec Native nightly 2012-03-18 on Google Nexus S with Android 4.0.3 (stock).
Comment 38 Jonathan Kew (:jfkthame) 2012-03-19 02:40:59 PDT
Created attachment 607091 [details] [diff] [review]
patch for aurora & beta

This is a rollup of the three r+'d patches that landed on m-c.

[Approval Request Comment]
Regression caused by (bug #): not a mozilla bug, workaround for regression caused by buggy Roboto font used on ICS devices in place of Droid Sans

User impact if declined: incorrect text rendering (character pair "ae" rendered as "æ") for users of devices with Android 4 ICS

Testing completed (on m-c, etc.): verified as fixing the issue in Nightly build

Risk to taking this patch (and alternatives if risky): minimal risk - simply avoids using the buggy opentype table in the Roboto font on Android ICS; no change to behavior on non-Android platforms

String changes made by this patch: none

Note that the font-prefs updates here lead to one reftest failure on android, as per bug 736726; hence the patch marks that test as failing. This does not indicate a significant rendering problem, only an overly fragile test.
Comment 39 Alex Keybl [:akeybl] 2012-03-20 13:13:34 PDT
Comment on attachment 607091 [details] [diff] [review]
patch for aurora & beta

[Triage Comment]
Approving for Aurora 13 and Beta 12 given the low risk evaluation and near-zero risk of regression on non-mobile platforms.
Comment 41 Makoto Kato [:m_kato] 2012-06-12 01:07:28 PDT
*** Bug 712752 has been marked as a duplicate of this bug. ***
Comment 42 Behdad Esfahbod 2012-12-21 19:48:54 PST
Jonathan, do you think it's worth moving the blacklisting machinery to HarfBuzz itself?  I mean, FreeType has something like this (using checksums).  I was hoping that we wouldn't have to do this in HarfBuzz, but if you are doing it in Firefox, well, there's no reason not to do in HarfBuzz.

Note You need to log in before you can comment on or make changes to this bug.