Last Comment Bug 716478 - MPL 2 upgrade: mozilla-central
: MPL 2 upgrade: mozilla-central
Status: RESOLVED FIXED
:
Product: mozilla.org
Classification: Other
Component: Licensing (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Gervase Markham [:gerv]
:
Mentors:
Depends on:
Blocks: 400964 mpl2 716479
  Show dependency treegraph
 
Reported: 2012-01-09 02:42 PST by Gervase Markham [:gerv]
Modified: 2013-02-07 19:25 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Gervase Markham [:gerv] 2012-01-09 02:42:23 PST
This bug tracks the MPL 2 upgrade for the project named in the subject line.
The repos are here: 
http://hg.mozilla.org/mozilla-central/
http://hg.mozilla.org/comm-central/

Gerv
Comment 1 Ed Morley [:emorley] 2012-05-15 05:02:17 PDT
(Popping this here so my comments don't get lost in scrollback)

Gerv, the latest m-c try run looks much better, just the B2G and Android failures left (the rest I've starred since it's all known intermittents):
https://tbpl.mozilla.org/?tree=Try&rev=8af7f8d3ef05

I'd guess the android issue looks like a problem with https://hg.mozilla.org/try/diff/8af7f8d3ef05/mobile/android/base/strings.xml.in 

For the B2G failure there's an error further back in the log that looks like the root cause: 
"ERROR - failed to load manifest file at 'b2g/config/tooltool-manifests/releng.manifest'"

So I'm presuming it doesn't like https://hg.mozilla.org/try/diff/8af7f8d3ef05/b2g/config/tooltool-manifests/releng.manifest
Comment 2 Ed Morley [:emorley] 2012-05-21 01:27:41 PDT
For people coming here from the tree closed status message:

The latest MPL2 update script has been run against m-c tip by gerv and pushed to try. Once that greens up, we'll push to m-c, merge to inbound and fx-team, wait for a bit of green and then re-open :-)
Comment 3 Ed Morley [:emorley] 2012-05-21 04:08:35 PDT
First try run today:
https://tbpl.mozilla.org/?tree=Try&rev=8c50ab7ec8d6

The orange M2 was due to bug 751842 landing a few hours after the last all-green MPL2 try run. Gerv excluded dom/imptests/* and pushed again, looking good so far:
https://tbpl.mozilla.org/?tree=Try&rev=0bd230403cec
Comment 5 Gervase Markham [:gerv] 2012-05-21 05:16:16 PDT
We are doing comm-central separately; see bug 757018. This bug should be used to track m-c only.

Gerv
Comment 6 Ed Morley [:emorley] 2012-05-21 08:04:32 PDT
All done here :-)

mozilla-central has been merged to inbound and fx-team, all is green & trees were reopened at ~1300 UTC+1. Any files added over the coming days/weeks that have the old header can be dealt with as dependants of bug 715549.

From Gerv's blog post:
> 15541 files changed, 48359 insertions(+), 494914 deletions(-) 

\o/
Comment 7 Colby Russell :crussell (no longer Mozilla-ing) 2013-02-07 19:25:49 PST
The license header in nsXULContentUtils.cpp included attribution to IBM in an idiosyncratic format.  It's still there.

http://mxr.mozilla.org/mozilla-central/source/content/xul/templates/src/nsXULContentUtils.cpp
http://hg.mozilla.org/mozilla-central/diff/f4157e8c4107/content/xul/templates/src/nsXULContentUtils.cpp

Note You need to log in before you can comment on or make changes to this bug.