Last Comment Bug 716532 - [New Tab Page] Remove "site strip" at the top and re-style buttons
: [New Tab Page] Remove "site strip" at the top and re-style buttons
Status: RESOLVED FIXED
: uiwanted
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 06:45 PST by Tim Taubert [:ttaubert]
Modified: 2012-04-11 06:01 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Mockup: restyled "site strip" buttons (736.63 KB, image/png)
2012-02-01 19:55 PST, Jennifer Morrow [:Boriss] (UX)
no flags Details
Icons: Three states for pin and X (thumbnail mouseover, icon mouseover, click) (7.00 KB, application/zip)
2012-02-01 19:56 PST, Jennifer Morrow [:Boriss] (UX)
no flags Details
patch v1 (10.84 KB, patch)
2012-02-03 06:17 PST, Tim Taubert [:ttaubert]
limi: ui‑review-
Details | Diff | Splinter Review

Description Tim Taubert [:ttaubert] 2012-01-09 06:45:38 PST
The black bar at the top that contains the "pin" and "remove" buttons should be removed. The buttons get a slight re-styling so that they can be stand-alone.
Comment 1 Chris Lee [:clee] 2012-01-09 10:13:32 PST
Agree here.  I believe this was a change Boriss was going to make?
Comment 2 Tim Taubert [:ttaubert] 2012-01-09 10:20:20 PST
Yes, Limi told me this so I figured Boriss knows about it :)
Comment 3 Jennifer Morrow [:Boriss] (UX) 2012-02-01 19:55:37 PST
Created attachment 593709 [details]
Mockup: restyled "site strip" buttons

Instead of a bar, let’s show only the two relevant icons in the same semi-transparent black at the bottom of the thumbnails.  The attached icons are all black, but at 50% opacity on thumbnail mouseover, 70% opacity on icon mouseover, and 90% opacity on click.  When the pin is activated, it should remain in 70% opacity.

It’s true that on some dark pages it will be harder to see the shapes.  But the alternative is a multi-colored icon which looks unlike the overall style of the page or a way to determine the darkness of the thumbnail and adjust accordingly - an option both more complicated and less consistent.  Considering the icons are the same on every thumbnail, simply having the 50% black opacity takes care of most cases and certainly doesn’t hamper a user who uses the icons and thus knows they are there.
Comment 4 Jennifer Morrow [:Boriss] (UX) 2012-02-01 19:56:25 PST
Created attachment 593710 [details]
Icons: Three states for pin and X (thumbnail mouseover, icon mouseover, click)
Comment 5 Tim Taubert [:ttaubert] 2012-02-03 06:17:29 PST
Created attachment 594156 [details] [diff] [review]
patch v1
Comment 6 Tim Taubert [:ttaubert] 2012-02-06 13:44:24 PST
Comment on attachment 594156 [details] [diff] [review]
patch v1

I figured that flagging a screenshot for review doesn't really make sense here. This patch is contained in the latest UX nightlies and waits for ux-review!
Comment 7 Siddhartha Dugar [:sdrocking] 2012-02-07 09:37:46 PST
On the latest UX build, the default, pinned and hovered states do not look very different. Also after pinning/unpinning a thumbnail and moving the mouse away, the pin icon does not disappear until another thumbnail is clicked. Is this by design?
Comment 8 Alex Limi (:limi) — Firefox UX Team 2012-02-07 16:27:39 PST
Comment on attachment 594156 [details] [diff] [review]
patch v1

Review of attachment 594156 [details] [diff] [review]:
-----------------------------------------------------------------

The difference between hovered states is not sufficient. How about we put a dark gray box around the elements when hovered, and keep the box when pinned? (sorry if this isn't a clear explanation, I'll talk to Boriss about it. :)
Comment 9 Tim Taubert [:ttaubert] 2012-02-15 17:54:28 PST
Waiting for new mockups and/or style directives.
Comment 10 Siddhartha Dugar [:sdrocking] 2012-02-19 04:34:48 PST
Please remove this from UX until an update is ready. (See reasons in comment 7 and comment 8)
Comment 11 Tim Taubert [:ttaubert] 2012-04-11 05:00:49 PDT
Fixed by bug 729878.

Note You need to log in before you can comment on or make changes to this bug.