[New Tab Page] Set to enabled by default on Nightly

VERIFIED FIXED in Firefox 12

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 13
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox12 verified)

Details

(Whiteboard: [qa!])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
We're gonna land this feature on trunk but pref'ed off. This bug has all the dependencies and the patch needed to enable it for Nightly users.
(Assignee)

Comment 1

6 years ago
Created attachment 586991 [details] [diff] [review]
patch v1

This patch enables the New Tab Page on Nightly, only. Keeps it disabled on Official, Unofficial and Aurora.
(Assignee)

Updated

6 years ago
Depends on: 716532, 455553
(Assignee)

Updated

6 years ago
Depends on: 716543
(Assignee)

Updated

6 years ago
Depends on: 716108
(Assignee)

Updated

6 years ago
Depends on: 715710
(Assignee)

Updated

6 years ago
Depends on: 704882
(Assignee)

Updated

6 years ago
Depends on: 705911
(Assignee)

Updated

6 years ago
Depends on: 716855
(Assignee)

Updated

6 years ago
Depends on: 705958
Depends on: 717109
Depends on: 717110
(Assignee)

Updated

5 years ago
Depends on: 717492
(Assignee)

Updated

5 years ago
Depends on: 718000
(Assignee)

Updated

5 years ago
No longer depends on: 716543
(Assignee)

Updated

5 years ago
No longer depends on: 718000
(Assignee)

Updated

5 years ago
No longer depends on: 705958
(Assignee)

Updated

5 years ago
Depends on: 721087
(Assignee)

Updated

5 years ago
No longer depends on: 704882
(Assignee)

Updated

5 years ago
Duplicate of this bug: 722643
(Assignee)

Updated

5 years ago
Attachment #586991 - Flags: review?(jwein)
(Assignee)

Comment 3

5 years ago
Clearing unresolved dependencies. We're not going to block on this to get early feedback on the New Tab Page.
No longer depends on: 705911, 716108, 716532
Comment on attachment 586991 [details] [diff] [review]
patch v1

Review of attachment 586991 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thanks for requesting review :)
Attachment #586991 - Flags: review?(jwein) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/ff95d5991457
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 12
Why does this patch mess with browser/branding/{aurora,official,unofficial}/pref/firefox-branding.js? Can't browser/branding/nightly/pref/firefox-branding.js override browser/app/profile/firefox.js?
(Assignee)

Comment 7

5 years ago
Backed out:

https://hg.mozilla.org/integration/fx-team/rev/5421a03367b8

Going to upload a new patch for tomorrow which just flips the pref for everyone and we're ready to back it out if it's not ready for Aurora in six weeks.
Whiteboard: [fixed-in-fx-team]
(Assignee)

Comment 8

5 years ago
Created attachment 593358 [details] [diff] [review]
patch v2
Attachment #586991 - Attachment is obsolete: true
Attachment #593358 - Flags: review?(jwein)
Attachment #593358 - Flags: review?(jwein) → review+
(Assignee)

Comment 9

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/29c4463e6a2e
Whiteboard: [fixed-in-fx-team]
Target Milestone: Firefox 12 → Firefox 13
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/mozilla-central/rev/29c4463e6a2e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Depends on: 723832
(Assignee)

Comment 11

5 years ago
Comment on attachment 593358 [details] [diff] [review]
patch v2

[Approval Request Comment]
Regression caused by (bug #): New feature, no regression.
User impact if declined: No New Tab Page :(
Testing completed (on m-c, etc.): 1-2 weeks baking time on Nightly.
String changes made by this patch: None.

We want to collect user feedback from more users. The New Tab Page should be enabled for Aurora 12, but will be disabled for Beta in ~4 weeks.
Attachment #593358 - Flags: approval-mozilla-aurora?

Comment 12

5 years ago
The approval from drivers is to pref this on for 1 wk starting today and we'll plan to pref this back off by next Thurs, 2/16.  

Can you file a separate bug to pref this back off next week?  Thanks!
Comment on attachment 593358 [details] [diff] [review]
patch v2

[Triage Comment]
Approving for Aurora 12 with the understanding that this will be pref'd off a week after landing.
Attachment #593358 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
Depends on: 725873
(Assignee)

Comment 14

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/ba0287a8920f

Filed bug 725873 to pref the New Tab Page off again after a week.

Updated

5 years ago
status-firefox12: --- → fixed
Verified fixed in Firefox 12.0b3.
Status: RESOLVED → VERIFIED
status-firefox12: fixed → verified
Whiteboard: [qa!]
Depends on: 985521
You need to log in before you can comment on or make changes to this bug.