Last Comment Bug 716590 - WalkStackMain64 shouldn't skip frames unless it's walking the thread that called NS_StackWalk
: WalkStackMain64 shouldn't skip frames unless it's walking the thread that cal...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Vladan Djeric (:vladan)
:
:
Mentors:
Depends on:
Blocks: 712109
  Show dependency treegraph
 
Reported: 2012-01-09 10:10 PST by Vladan Djeric (:vladan)
Modified: 2012-01-24 04:58 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.75 KB, patch)
2012-01-09 10:17 PST, Vladan Djeric (:vladan)
dbaron: review+
Details | Diff | Splinter Review

Description Vladan Djeric (:vladan) 2012-01-09 10:10:51 PST
WalkStackMain64 currently skips the top 3 frames of a stack because it assumes that it is walking the stack of the thread that called NS_StackWalk. However, since bug 713278, NS_StackWalk can walk the stack of any arbitrary thread, in which case it should not skip over any frames.
Comment 1 Vladan Djeric (:vladan) 2012-01-09 10:17:51 PST
Created attachment 587032 [details] [diff] [review]
Patch v1
Comment 2 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-01-19 14:24:12 PST
Comment on attachment 587032 [details] [diff] [review]
Patch v1

>+    int skip = (data->walkCallingThread ? 3 : 0 ) + data->skipFrames;

No space before the ")".

r=dbaron
Comment 4 Marco Bonardo [::mak] 2012-01-24 04:58:09 PST
https://hg.mozilla.org/mozilla-central/rev/f531dd09e05b

Note You need to log in before you can comment on or make changes to this bug.