Closed Bug 716725 Opened 8 years ago Closed 8 years ago

Fennec not respecting CSS min-width (or something)

Categories

(Core :: Layout: Block and Inline, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: justin.lebar+bug, Assigned: jwir3)

References

Details

(Keywords: testcase, Whiteboard: [readability])

Attachments

(1 file)

In bug 683284, I wrote some CSS which attempts to make about:memory wider in Fennec, so text isn't cut off.

It works fine in a thin desktop window, but it doesn't work on native Fennec.  The text only takes up half the window, but it should take up the whole window.

I'm happy to write a minimized testcase, but right now Fennec dies as soon as I click the URL bar (Nexus S running ICS, OS pops up a stopped-responding dialog), so that's hard.

So for now, the STR are: Build Fennec with the patch from bug 683284 applied.  Open about:memory.  Text should fill the screen (and, in fact, the layout viewport should be wider than the screen) but takes up only about half the screen.

Untested minimized testcase (may or may not trigger the bad behavior):

<div style='min-width: 75ex; background: green'>
<pre style='overflow-x: hidden; text-overflow: ellipsis'>This is a very long line.  It should be so long that it overflows the screen.  Except there should be an ellipsis...</pre>
</div>
Blocks: image-suck
Er, wrong bug number.  Should be bug 706431.
Blocks: 706431
No longer blocks: image-suck
This is about Fennec Native, right?
Product: Fennec → Fennec Native
(In reply to Steffen Wilberg from comment #2)
> This is about Fennec Native, right?

Yes.  (I didn't realize it had its own product!)
Assignee: nobody → mbrubeck
Priority: -- → P3
This is caused by font inflation (bug 627842).  As the container gets wider, the text gets proportionally larger, so it ends up getting cut off just as much.  If you set the "Font size" pref in Fennec to "Tiny" then you can see the correct (non-inflated) layout.  You can also work around this problem by setting style="-moz-text-size-adjust: none;" on the affected elements.

This should be fixed by bug 706198, which will disable font inflation on XUL pages.  Not sure whether it should be marked duplicate; marking as dependent for now so that it can be verified after bug 706198 is fixed.
Assignee: mbrubeck → sjohnson
Depends on: 706198
Whiteboard: [readability]
Isn't this a bug which affects websites trying to have a similar layout?
Component: General → Layout: Block and Inline
Product: Fennec Native → Core
QA Contact: general → layout.block-and-inline
Attached file Testcase #1
This looks fine to me on both Fennec Linux and Android.
The two lines renders the same, except that the first one has an ellipsis.
Keywords: testcase
Whiteboard: [readability] → [readability] WORKSFORME?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [readability] WORKSFORME? → [readability]
You need to log in before you can comment on or make changes to this bug.