Closed Bug 716933 Opened 8 years ago Closed 8 years ago

Can't invite/add people to an event

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

Lightning 1.2
All
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: WSourdeau)

References

Details

(Keywords: regression)

Lightning version 1.2b1
gdata-provider 0.9

Using a zimbra based calendar, if I add attendees to an event using the invite attendees dialog, then I am unable to save the event (and I believe invites don't get sent either). The error console shows:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [calICalendarACLEntry.getUserAddresses]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://calendar/content/calendar-event-dialog.js :: saveItem :: line 2308"  data: no]

Even removing the people again doesn't let me save the event.
Sounds like another regression from Bug 586276.
Blocks: 586276
Keywords: regression
Version: Trunk → Lightning 1.2
We found the issue here, it was my fault :-) r=philipp via irc, see push for patch
Pushed to comm-central changeset 6e42a9a28e06
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4
Backported to releases/comm-aurora changeset 3ddbfbd0db43
Target Milestone: 1.4 → 1.3
Backported to releases/comm-beta changeset 076bf34c86a0
Target Milestone: 1.3 → 1.2
I filed bug 716975 to fix pyxpidl, btw.
Duplicate of this bug: 717139
Assignee: nobody → WSourdeau
You need to log in before you can comment on or make changes to this bug.