Closed Bug 716935 Opened 12 years ago Closed 11 years ago

on accessibility branch mac osx64 opt mochitest-a11y does the timed out after 330 seconds with no output thing.

Categories

(Core :: Disability Access APIs, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 835338

People

(Reporter: tbsaunde, Assigned: hub)

References

(Blocks 1 open bug)

Details

As a first gues, I'm going to gues a11y isn't enabled in the branch builds, someone want to check this out?
Since I'm pretty sure we don't run mochitest-a11y on mozilla-central for either debug  and certainly don't built it for opt I'm going to star this issue on the branch as this bug. To explain  what's happening.
accessibility is not enabled on mac by default.
(In reply to Hub Figuiere [:hub] from comment #2)
> accessibility is not enabled on mac by default.

on opt builds we ship from m-c yes I know, but we've had the branches config setup differently in the past, and it would probably be preferable we restore those configs if they have infact changed somehow, probably as a part of the mozconfigs in source tree thing.
I definitely see a mochitest-a11y failure on MacOS.
Assignee: nobody → hub
Blocks: osxa11y
I guess this when I run locally 

3775 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_focus_autocomplete.xul | wrong state bits for ['input node', address: 0x151ea9720, role: entry, name: 'Search using Yahoo', address: 0x14f130e20]!
3776 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_focus_autocomplete.xul | Focussed ['input node', address: 0x151ea9720, role: entry, name: 'Search using Yahoo', address: 0x14f130e20] must be focusable!
3777 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_focus_autocomplete.xul | Editable ['input node', address: 0x151ea9720, role: entry, name: 'Search using Yahoo', address: 0x14f130e20] cannot be readonly!
3778 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_focus_autocomplete.xul | Singleline ['input node', address: 0x151ea9720, role: entry, name: 'Search using Yahoo', address: 0x14f130e20] cannot be multiline!
3779 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_focus_autocomplete.xul | test with ID = ' 'searchbar'  'enter ' key' failed. No focus event.
3780 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_focus_autocomplete.xul | test with ID = ' 'searchbar'  'enter ' key' failed. There is unexpected focus event.
3781 INFO TEST-INFO | chrome://mochitests/content/a11y/accessible/events/test_focus_autocomplete.xul | Invoke the '['button node', address: 0x1502fd9d0, role: pushbutton, name: 'Search using Yahoo', address: 0x152af8470] click' test { expected 'focus' event; unexpected 'focus' event;  }
NOTE: child process received `Goodbye', closing down
WARNING: NS_ENSURE_TRUE(compMgr) failed: file /Users/hub/source/mozilla/mozilla-central/obj-ff-dbg/xpcom/build/nsComponentManagerUtils.cpp, line 81
nsStringStats
 => mAllocCount:             78
 => mReallocCount:            1
 => mFreeCount:              78
 => mShareCount:            124
 => mAdoptCount:              0
 => mAdoptFreeCount:          0
WARNING: 1 sort operation has occurred for the SQL statement '0x11a159860'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file /Users/hub/source/mozilla/mozilla-central/storage/src/mozStoragePrivateHelpers.cpp, line 144
WARNING: An error occured during async execution: 21 not an error: file /Users/hub/source/mozilla/mozilla-central/storage/src/VacuumManager.cpp, line 110
WARNING: 1 sort operation has occurred for the SQL statement '0x129843f60'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file /Users/hub/source/mozilla/mozilla-central/storage/src/mozStoragePrivateHelpers.cpp, line 144
WARNING: 1 sort operation has occurred for the SQL statement '0x129844080'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file /Users/hub/source/mozilla/mozilla-central/storage/src/mozStoragePrivateHelpers.cpp, line 144
Blocks: 733513
Blocks: 746160
No longer blocks: 733513
beside bug 835338, mochitest pass on Mac.

Marking as dupe of it (instead of WFM).
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.