Last Comment Bug 716949 - [Page Thumbnails] Cached images are discarded way too easily
: [Page Thumbnails] Cached images are discarded way too easily
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: 13 Branch
: All All
: -- normal with 1 vote (vote)
: Firefox 12
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 736709 738120 (view as bug list)
Depends on: 744388
Blocks: 497543
  Show dependency treegraph
 
Reported: 2012-01-10 10:41 PST by Tim Taubert [:ttaubert] (on PTO, back Aug 29th)
Modified: 2014-01-14 10:16 PST (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-01-10 10:41:48 PST
Thumbnails are currently stored in the file cache. Unfortunately, the file cache gets purged way too often (crash, force-quit, clear history [on shutdown], cache full). We need a way to pin special items (like our thumbnails) in the cache so that they don't get lost that easily.
Comment 1 Virgil Dicu [:virgil] [QA] 2012-02-21 08:56:34 PST
Juts want to add another case in favour of this: the cache is cleared with a clean profile after the first restart on Windows, thus all thumbnails from sites visited in the first run will be blank after the first restart.
Comment 2 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-03-19 04:02:22 PDT
*** Bug 736709 has been marked as a duplicate of this bug. ***
Comment 3 Virgil Dicu [:virgil] [QA] 2012-03-27 02:55:18 PDT
*** Bug 738120 has been marked as a duplicate of this bug. ***
Comment 4 Brian Smith (:briansmith, :bsmith, use NEEDINFO?) 2012-03-27 03:17:19 PDT
(In reply to Tim Taubert [:ttaubert] from comment #0)
> Thumbnails are currently stored in the file cache. Unfortunately, the file
> cache gets purged way too often (crash, force-quit, clear history [on
> shutdown], cache full). We need a way to pin special items (like our
> thumbnails) in the cache so that they don't get lost that easily.

I highly recommend that you do not store these in the cache to start with. 

Realistically, there are always going to be times when we clear the disk cache due to one kind of crash or another. We (the networking team) are going to greatly reduce the frequency of these events. But, even that reduction is more than a quarter away. If you need a solution for this problem in Q2 then you should move the storage of the thumbnails elsewhere. If you can wait until Q3 then coordinate with Michal and Nick to see if they can promise a solution in Q3.

See also bug 738128.
Comment 5 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-04-11 06:57:52 PDT
(In reply to Brian Smith (:bsmith) from comment #4)
> (In reply to Tim Taubert [:ttaubert] from comment #0)
> > Thumbnails are currently stored in the file cache. Unfortunately, the file
> > cache gets purged way too often (crash, force-quit, clear history [on
> > shutdown], cache full). We need a way to pin special items (like our
> > thumbnails) in the cache so that they don't get lost that easily.
> 
> I highly recommend that you do not store these in the cache to start with.

Thank you for your advice. We're going to build a custom thumbnail storage in the near future that won't use the file cache.
Comment 6 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-04-11 07:19:39 PDT
Will be fixed by bug 744388.
Comment 7 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-05-02 06:51:11 PDT
Fixed by bug 744388.
Comment 8 Honza Bambas (:mayhemer) 2014-01-14 10:16:14 PST
Since this is fixed, probably no longer deps on bug 105843.

Note You need to log in before you can comment on or make changes to this bug.