Closed Bug 717044 Opened 9 years ago Closed 8 years ago

Session store should be aware of browser.newtab.url

Categories

(Firefox :: Session Restore, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ttaubert, Unassigned)

References

Details

Session store handles only 'about:blank' as a new tab page. When bug 455553 has landed it should handle the url in 'browser.newtab.url' additionally as a new tab page (and don't store it in history as single tab entry, etc).
Hmm, the newtab is going to be much less blank than about:blank, so we'll want to be careful here.
Duplicate of this bug: 743561
I'd like to provide a patch, if this is still wanted.
Michael, thanks for your initiative but as about:newtab merged with about:home will possibly contain form data in the future I don't think it makes sense to waste time on doing this just to rip it out later.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.