Last Comment Bug 717219 - Source Editor should highlight the current line in HTML documents
: Source Editor should highlight the current line in HTML documents
Status: RESOLVED FIXED
[sourceeditor][orion][fixed-in-fx-team]
: dev-doc-complete
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 13
Assigned To: Mihai Sucan [:msucan]
:
Mentors:
Depends on: 707987
Blocks: 712982
  Show dependency treegraph
 
Reported: 2012-01-11 05:56 PST by Panos Astithas [:past] (away until 7/21)
Modified: 2012-04-29 16:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
proposed patch (11.16 KB, patch)
2012-01-27 13:20 PST, Mihai Sucan [:msucan]
rcampbell: review+
Details | Diff | Splinter Review
some fixes (10.52 KB, patch)
2012-02-01 12:54 PST, Mihai Sucan [:msucan]
no flags Details | Diff | Splinter Review
[in-fx-team] rebased patch (12.44 KB, patch)
2012-02-09 09:32 PST, Mihai Sucan [:msucan]
no flags Details | Diff | Splinter Review

Description Panos Astithas [:past] (away until 7/21) 2012-01-11 05:56:17 PST
The script debugger sometimes displays HTML documents for inline scripts. In these cases we need to have SE_setMode do setHighlightCaretLine(true), as it does for JS and CSS files.
Comment 1 Mihai Sucan [:msucan] 2012-01-11 07:29:26 PST
Thanks for the bug report!


(In reply to Panos Astithas [:past] from comment #0)
> The script debugger sometimes displays HTML documents for inline scripts. In
> these cases we need to have SE_setMode do setHighlightCaretLine(true), as it
> does for JS and CSS files.

The highlighter for HTML mode does not have the setHighlightCaretLine(true) method, unfortunately. The approach there is different...
Comment 2 Mihai Sucan [:msucan] 2012-01-27 13:20:23 PST
Created attachment 592244 [details] [diff] [review]
proposed patch

This changes the way the current line highlight is implemented, as suggested by the Orion team. Now it works with the HTML mode as well.

Please let me know if this is fine with you.
Comment 3 Rob Campbell [:rc] (:robcee) 2012-01-28 07:17:48 PST
Comment on attachment 592244 [details] [diff] [review]
proposed patch

looks good.
Comment 4 Mihai Sucan [:msucan] 2012-02-01 12:54:03 PST
Created attachment 593577 [details] [diff] [review]
some fixes

Found a minor bug while working on the rest of the patches in my queue. Fixed.

Thanks for the r+!
Comment 5 Mihai Sucan [:msucan] 2012-02-09 09:32:18 PST
Created attachment 595782 [details] [diff] [review]
[in-fx-team] rebased patch
Comment 6 Mihai Sucan [:msucan] 2012-02-09 11:12:05 PST
We need to document the new highlightCurrentLine option. Thanks!
Comment 7 Mihai Sucan [:msucan] 2012-02-18 04:09:07 PST
Comment on attachment 595782 [details] [diff] [review]
[in-fx-team] rebased patch

Landed:
https://hg.mozilla.org/integration/fx-team/rev/0815f202f7f1
Comment 8 Mihai Sucan [:msucan] 2012-02-18 08:38:09 PST
Comment on attachment 595782 [details] [diff] [review]
[in-fx-team] rebased patch

backedout due to test failure:
https://hg.mozilla.org/integration/fx-team/rev/b18c023badad
Comment 9 Mihai Sucan [:msucan] 2012-02-21 10:48:02 PST
Comment on attachment 595782 [details] [diff] [review]
[in-fx-team] rebased patch

Landed:
https://hg.mozilla.org/integration/fx-team/rev/aa44ffe9db74
Comment 10 Rob Campbell [:rc] (:robcee) 2012-02-22 09:47:59 PST
https://hg.mozilla.org/mozilla-central/rev/aa44ffe9db74
Comment 11 Eric Shepherd [:sheppy] 2012-04-29 16:56:18 PDT
Already documented, tweaked to mention that it's new in Firefox 13.

https://developer.mozilla.org/en/JavaScript_code_modules/source-editor.jsm#Configuration_defaults_constants
https://developer.mozilla.org/en/JavaScript_code_modules/source-editor.jsm#The_editor_configuration_object

Added to Firefox 13 for developers.

Note You need to log in before you can comment on or make changes to this bug.