Migrate nightly.mozilla.org to mozilla.org/firefox/nightly

RESOLVED WONTFIX

Status

www.mozilla.org
Pages & Content
RESOLVED WONTFIX
5 years ago
5 months ago

People

(Reporter: mcbmoz, Unassigned)

Tracking

unspecified
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=dev c=redirect p=2, URL)

(Reporter)

Description

5 years ago
Opening this bug to have nightly.mozilla.org moved into One Mozilla.

James/Steven, Matt M., built and has updated the nightly.mozilla.org page, adding him here for any pings as needed.

Goal: move nightly.mozilla.org into One Mozilla, set 301 redirects to mozilla.org/firefox/nightly

We want to do this to reduce the need to update the header/footer, which are currently very out of date, and consolidate the channel content, reducing the number of websites out in Mozilla universe.

James/Steven, what a reasonable milestone? I'm setting for 1.3, but we have a little wiggle room. We'd like to get this out of the way before the Q1 goals get a bit hairy and in advance of migrating to Bedrock.

Asa/Product and PMM team have signed off on this consolidation.
I don't really know anything about the nightly site, but I know it's a django thing. I'm not sure if there's anything in there that will be hard to port. tofumatt?

Comment 2

5 years ago
(In reply to James Long (:jlongster) from comment #1)
> I don't really know anything about the nightly site, but I know it's a
> django thing. I'm not sure if there's anything in there that will be hard to
> port. tofumatt?

It's not actually a Django thing, it's just a Python script that scrapes the Nightly FTP folders then uses Jinja2 to spit out some HTML files (a poor man's static site generator).

I don't know if it requires any "porting", really. If you can have custom views in bedrock that just run something, output HTML, then finish up, you could include the scraper script and be fine. It's kind of hacky Python that's quite old, but it does work just fine.
(In reply to Matthew Riley MacPherson [:tofumatt] from comment #2)
> 
> It's not actually a Django thing, it's just a Python script that scrapes the
> Nightly FTP folders then uses Jinja2 to spit out some HTML files (a poor
> man's static site generator).

Oh, cool. This will probably be done in the PHP site first, but we can just make some cron jobs that run those scripts. I suppose the only work to be done is to replace the header and footer with our stuff. Still not sure how much work that is. Who's going to be doing this? Steven? It shouldn't be too hard, just consolidating markup and css.

Comment 4

5 years ago
The header and footer uses Django Moz Header, it just has special CSS to make it all dark and creepy. If you move it to PHP it would be weird, if you're using python/Django this should be a snap. Ping me if you need a hand though.

Updated

5 years ago
Depends on: 714887

Updated

5 years ago
Target Milestone: 1.3 → 1.4

Updated

5 years ago
Target Milestone: 1.4 → 1.5
(Reporter)

Comment 5

5 years ago
James/Matt, do you think we can get this into the 1.5 release or should we move it to 1.6?
This is somewhat low priority for me, but I can try to get it done by 1.6. Definitely not 1.5 though.
(Reporter)

Updated

5 years ago
Blocks: 723732

Updated

5 years ago
Target Milestone: 1.5 → 1.6
(Reporter)

Comment 7

5 years ago
Reassigning to Craig, and moving to 1.7.

Craig, ping me, TofuMatt, James, Fred with questions.
Assignee: jlong → craigcook.bugz
Target Milestone: 1.6 → 1.7
After discussing this some more, I'm giving it back to jlongster to tackle as part of the me bedrock migration. The technologies match already.

The only thing that'll need to change in the process is the CSS, so I am leaving the exact timeline up to James et al. Please minimize any duplicated effort.
Assignee: craigcook.bugz → jlong

Updated

5 years ago
Target Milestone: 1.7 → 1.9

Updated

5 years ago
Target Milestone: 1.9 → 1.8

Updated

5 years ago
Target Milestone: 1.8 → 1.9

Updated

5 years ago
Target Milestone: 1.9 → 1.10

Updated

5 years ago
Target Milestone: 1.10 → 2.0

Comment 9

5 years ago
James, any update here? Looks like this fell off the radar a bit with the Bedrock push, but would be nice to knock it out as part of a Bedrock phase 2.
Unless I am missing something, this is blocked on having a datastore (database!) for mozilla.org. We can fetch the filenames every night, but we need to put them somewhere.

Comment 11

5 years ago
Is there a bug for that then?
Sheeri: What's the status of databases for Bedrock in both data centers?
I think the idea of the scraper is to output straight HTML files, not sure though. I haven't had time to do this, and will see if it's possible soon. A database would be great though.
Yeah currently it spits out straight HTML files, but in the future, it'll need to store the data somewhere, then render it up as a normal bedrock page.

All right, this will be a new feature for bedrock after it's got a DB (I am sure Sheeri will answer comment 12 when she's available). Unassigning James, but feel free to get this prioritized with the Web Prod team as part of one of the upcoming mozilla.org releases.
Assignee: jlong → nobody
Fred - the bedrock servers are set up, with bedrock1.db.scl3.mozilla.com being the primary write master and bedrock2 being the primary read master (but we can manually failover to bedrock2 if bedrock1 dies).

Only the monitoring and replication and root users have been set up, and no data has been imported. If you want us to set up additional users or import data, let us know.

(and yes, I was at a conference last week, sorry for the late reply)
tagging "future" and will add to an upcoming milestone when ready to move forward.

Is there anything else needed?
Target Milestone: 2.0 → Future
(Assignee)

Updated

5 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Updated

5 years ago
Whiteboard: u=dev c=redirect p=2

Updated

4 years ago
Depends on: 750102
OS: Mac OS X → All
Hardware: x86 → All

Updated

4 years ago
No longer depends on: 750102

Updated

4 years ago
Depends on: 737697

Updated

4 years ago
Duplicate of this bug: 713024

Updated

4 years ago
Blocks: 540022

Updated

4 years ago
Blocks: 722096

Updated

4 years ago
Component: General → Pages & Content

Comment 18

3 years ago
Would this be able to get done soon

Comment 19

3 years ago
(In reply to David Weir (satdav) from comment #18)
> Would this be able to get done soon

This will be done in July 2014 when the new Firefox channels page is launched, which will deprecate the need to migrate the nightly page to bedrock. The channels page will handle nightly, aurora, beta, and release channels in one user experience.
Depends on: 1005237

Comment 20

2 years ago
:jbertsch is the channels page still due another redesign to integrate nightly, as suggested in comment #19, or is there some other plan for integrating nightly downloads into bedrock?
Flags: needinfo?(jbertsch)
(In reply to Josh Mize [:jgmize] from comment #20)
> :jbertsch is the channels page still due another redesign to integrate
> nightly, as suggested in comment #19, or is there some other plan for
> integrating nightly downloads into bedrock?

Yes, that is still the plan.  However, that plan is currently unprioritized and lacking a live date.  Let me see if I can get it prioritized for Q2 (or Q3) this year?
Flags: needinfo?(jbertsch)
(In reply to Jennifer Bertsch [:jbertsch] from comment #21)
> (In reply to Josh Mize [:jgmize] from comment #20)
> > :jbertsch is the channels page still due another redesign to integrate
> > nightly, as suggested in comment #19, or is there some other plan for
> > integrating nightly downloads into bedrock?
> 
> Yes, that is still the plan.  However, that plan is currently unprioritized
> and lacking a live date.  Let me see if I can get it prioritized for Q2 (or
> Q3) this year?


Can it be Q2? We lack users of localized builds on the Nightly channel because nightly.mozilla.org only offers en-US builds, moving that to Bedrock would allow us to make these builds discoverable as we can offer localized pages and download buttons on mozilla.org

Comment 23

10 months ago
After meeting with Jbertsch and pmac during the London all hands, we decided to prgressively deprecate nightly.mozilla.org in favor of www.mozilla.org at least for Desktop Nightly and the release management team will provide the web dev resources to make that happen. We will not expose Nightly in the main navigation path as the goal is not to drive regular users to download nightly but to avoid duplication of work and benefit from bedrock l10n infrastructure.

Updated

10 months ago
Depends on: 1285980

Updated

10 months ago
Blocks: 1285980
No longer depends on: 1285980

Updated

9 months ago
Assignee: nobody → kohei.yoshino
Blocks: 1280394
Status: NEW → ASSIGNED

Updated

9 months ago
Depends on: 1288544

Updated

9 months ago
No longer blocks: 1285980

Updated

9 months ago
Assignee: kohei.yoshino → nobody
Status: ASSIGNED → NEW

Comment 24

8 months ago
Today's blog post (https://blog.mozilla.org/nnethercote/2016/09/09/how-to-get-localized-firefox-nightly-builds/) links to:
https://www.mozilla.org/en-US/firefox/nightly/all/

...however this 404s.
Flags: needinfo?(n.nethercote)

Comment 25

8 months ago
Bah that should have been on bug 1288544.
> https://www.mozilla.org/en-US/firefox/nightly/all/
> 
> ...however this 404s.

It's working for me. I tried two different browsers.
Flags: needinfo?(n.nethercote)

Comment 27

8 months ago
It 404ed for me last night from multiple browsers, but works now.
I'm in the UK so presuming the new page just hadn't propagated fully to all CDN regions (the page is served by CloudFlare).

Updated

8 months ago
Depends on: 1301650
Depends on: 1307091

Updated

5 months ago
Depends on: 1320098

Updated

5 months ago
No longer depends on: 1301650
This bug is actually WONTFIX since we are not going to have a dedicated Nightly product page on www.mozilla.org at this time. Meanwhile, https://nightly.mozilla.org/ will be redirected to https://www.mozilla.org/firefox/channel/desktop/#nightly as proposed in Bug 1301642.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX

Updated

5 months ago
No longer blocks: 1280394
No longer depends on: 1320098
You need to log in before you can comment on or make changes to this bug.