Closed Bug 717779 Opened 11 years ago Closed 5 years ago

Implement the new doorhanger style install flow for add-on installation from about:addons

Categories

(Toolkit :: Add-ons Manager, defect, P3)

defect
Points:
3

Tracking

()

RESOLVED WONTFIX

People

(Reporter: eviljeff, Unassigned)

References

Details

(Whiteboard: [hijacking][fxsearch])

Attachments

(1 file)

If a preliminary add-on is installed via the search results in about:addons there isn't any confirmation or warning about it only being preliminary reviewed.  As preliminary add-ons can sometimes not work at all (they often arn't tested as part of the review process).

On AMO these add-ons are indicated with a different button and a confirmation if not logged in.  We need the same kind of confirmation in client.
Or they could have different styling (possibly text as well) in the listing in the search results?
I propose this is clearly restyled (like it was on the AMO pages) with signal colors (green / yellow) and a tooltip text added (Extension not reviewed by Mozilla!). Also styling should be done via CSS classes to make it themable.
If we do allow theme developers to modify the styling of the button we need to have a validator warning for it AND strict limitations as how it must be styled (similar to the identity box). In truth, I don't think add-ons with only a preliminary review should show up in about:addons at all. Only fully reviewed add-ons should be displayed there.
not sure if I agree about completely hiding them, but maybe the correct, complete addon name should have to be entered to get a match from prelim.
As I recall, they didn't show up in about:addons until recently. If they're to continue appearing, there needs to be a styling difference like Axel's mockup and a warning before install that the add-on is experimental like we get on AMO for add-ons not compatible with the current platform.
(In reply to KLB from comment #3)
> If we do allow theme developers to modify the styling of the button we need
> to have a validator warning for it AND strict limitations as how it must be
> styled (similar to the identity box). 

that would be a separate bug (in a different product and component)

> In truth, I don't think add-ons with
> only a preliminary review should show up in about:addons at all. Only fully
> reviewed add-ons should be displayed there.

The change was made as it was deemed inconsistent that you'd get a match if you searched for something on AMO directly but not via the addons manager.  If you believe strongly enough in this then file a new bug asking for the change (I suspect it will be wontfixed though)
To add to Kris's comment, any styling difference needs to be easy to implement by theme developers, specified in theme testing guidelines and strictly enforced. There also needs to be an easy and quick way to test themes to make sure styling is appropriate. We don't need to unduly complicate the theme testing process for AMO editors nor theme developers.

This may require a permanently prelimined test add-on with a unique search phrase that could be put in the about:addons search box. Again this would complicate the reviewing of themes. 

I am really in the belief that add-ons that have not been fully reviewed should not be appearing in about:add-ons.
> I am really in the belief that add-ons that have not been fully reviewed should not be appearing in about:add-ons.

Is there a separate bug filed for this?
Duplicate of this bug: 1114770
Morphing this bug to be about implementing the new unified install flow for add-ons, ideally just reusing the work from bug. This will include a warning step for preliminarily reviewed add-ons.

Mocks to be attached shortly.
Points: --- → 3
Depends on: 1123914
Flags: qe-verify+
Flags: firefox-backlog+
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: preliminary reviewed add-ons should show a confirmation dialog/warning → Implement the new doorhanger style install flow for add-on installation from about:addons
Depends on: 1123926
Depends on: 1120996
No longer depends on: 1123926
Depends on: 1139656
No longer blocks: signed-addons
No longer depends on: 1123914
Priority: -- → P3
Whiteboard: [fxsearch][searchhijacking]
Whiteboard: [fxsearch][searchhijacking] → [hijacking][fxsearch]
Rank: 35
I think this has all changed a lot with the new disco pane, firefox 57 and so on. I hope that we'll change the search page to just be an AMO page and remove all the XUL we have for that right now. That's bug 1263313. Assuming this is a won't fix as a result.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.