Last Comment Bug 717881 - The default tab icon used on Mac doesn't exist
: The default tab icon used on Mac doesn't exist
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86 Mac OS X
: -- minor (vote)
: Thunderbird 18.0
Assigned To: Andreas Nilsson (:andreasn)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-13 02:43 PST by Florian Quèze [:florian] [:flo] (PTO until August 29th)
Modified: 2012-09-24 15:15 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch to fix the issue (2.20 KB, patch)
2012-07-11 07:15 PDT, Andreas Nilsson (:andreasn)
richard.marti: review+
Details | Diff | Splinter Review

Description Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-01-13 02:43:50 PST
With a debug build I see this in my terminal:
Chrome file doesn't exist: [...]/obj-tbird/mozilla/dist/DailyDebug.app/Contents/MacOS/chrome/toolkit/skin/classic/global/tree/item.png

An MXR search shows that this file is referenced from:

http://mxr.mozilla.org/comm-central/source/mail/themes/pinstripe/mail/tabmail.css#48
48 .tabmail-tab {
49   list-style-image: url("chrome://global/skin/tree/item.png");
50 }

and from:
334 .alltabs-item {
335   list-style-image: url("chrome://global/skin/tree/item.png");
336 }

This item.png file doesn't exist.

This seems to cause the alltabs menu item for the inbox and email messages to not have any icon.
While the default icon should be fixed, we should probably also see why alltabs menuitem attempt to use it instead of the icon that these tabs have in the tab bar.
Comment 1 Stefan [:stefanh] 2012-01-26 12:49:53 PST
item.png was removed in bug 648668 (looks like it was replaced with chrome://mozapps/skin/places/defaultFavicon.png).
Comment 2 Stefan [:stefanh] 2012-01-26 12:52:26 PST
(In reply to Stefan [:stefanh] from comment #1)
> item.png was removed in bug 648668 (looks like it was replaced with
> chrome://mozapps/skin/places/defaultFavicon.png).

Oh, well - I don't think that defaultFavicon.png would be suitable here (just looked at it).
Comment 3 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-04-26 08:05:00 PDT
I was about to file a dup of this bug, mostly because I'm annoyed by the noise in the terminal, but it would be good to have some relevant icons displayed in the all tabs menu popup too. CC'ing Andreas
Comment 4 Stefan [:stefanh] 2012-04-26 10:58:41 PDT
One cheap solution is to take the icon from 2.0 (http://mxr.mozilla.org/mozilla2.0/source/toolkit/themes/pinstripe/global/tree/item.png) and put it in mail/themes.
Comment 5 Andreas Nilsson (:andreasn) 2012-07-11 07:15:51 PDT
Created attachment 641047 [details] [diff] [review]
patch to fix the issue

I haven't tested this, but I think it should do the trick.
Comment 6 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-08-09 08:54:41 PDT
I've just tested attachment 641047 [details] [diff] [review] and I can confirm that the warning in comment 0 no longer exists.

(In reply to Florian Quèze [:florian] [:flo] from comment #0)

> This item.png file doesn't exist.
> 
> This seems to cause the alltabs menu item for the inbox and email messages
> to not have any icon.

This is fixed by the patch here.

> While the default icon should be fixed, we should probably also see why
> alltabs menuitem attempt to use it instead of the icon that these tabs have
> in the tab bar.

I think we should fix this too, but we can handle it in another bug.

I was about to file a dup again for this today. Could we please get the fix reviewed and landed soon? :) (I almost put an r+ on the attachment after testing it and verifying that it works, but I'm not a peer for mail/themes/)
Comment 7 Florian Quèze [:florian] [:flo] (PTO until August 29th) 2012-09-12 07:25:29 PDT
(In reply to Florian Quèze [:florian] [:flo] from comment #6)

> > While the default icon should be fixed, we should probably also see why
> > alltabs menuitem attempt to use it instead of the icon that these tabs have
> > in the tab bar.
> 
> I think we should fix this too, but we can handle it in another bug.

This has been fixed in bug 464524 :-).
Comment 8 Andreas Nilsson (:andreasn) 2012-09-12 07:33:22 PDT
Comment on attachment 641047 [details] [diff] [review]
patch to fix the issue

Setting up for review.
Comment 9 Richard Marti (:Paenglab) 2012-09-12 11:22:31 PDT
Comment on attachment 641047 [details] [diff] [review]
patch to fix the issue

This looks good.
Comment 10 Ludovic Hirlimann [:Usul] 2012-09-21 07:13:52 PDT
No checkin-needed ?
Comment 11 Ryan VanderMeulen [:RyanVM] 2012-09-24 15:15:41 PDT
https://hg.mozilla.org/comm-central/rev/18d35f49e7fd

Note You need to log in before you can comment on or make changes to this bug.