Closed Bug 717902 Opened 8 years ago Closed 8 years ago

Form autocomplete pop-up with the available suggestions is not displayed in landscape mode when HKB is used

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 12

People

(Reporter: carla.nadastean, Assigned: alexp)

Details

Attachments

(1 file)

Build: Fennec/12.0a1 (2012-01-13)
HTC Desire Z (Android 2.3)

Steps to reproduce:
1. Open Fennec app in landscape mode.
2. Navigate to http://mail.yahoo.com
3. Fill in username and password. (e.g carla_test@yahoo.com) (Select "Never" or "Not Now" option for Remember password pop-up)
4. Sign out and go back to http://mail.yahoo.com .
5. Try to fill in the same username using the HKB (carla_test)

Expected Result:
Form autocomplete pop-up with the available suggestions is displayed.

Actual Result: 
Form autocomplete pop-up with the available suggestions is not displayed.
Probably a regression from bug 715889. It would seem that mIMELandscapeFS is true even for hardward keyboards.

Maybe using imm.isFullscreenMode() is a better approach?
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/AwesomeBar.java#176
Assignee: nobody → margaret.leibovic
(In reply to Mark Finkle (:mfinkle) from comment #1)
> Probably a regression from bug 715889. It would seem that mIMELandscapeFS is
> true even for hardward keyboards.
> 
> Maybe using imm.isFullscreenMode() is a better approach?
> http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/AwesomeBar.
> java#176

I only have a phone with a virtual keyboard (Motorola Atrix w/ Android 2.3), but when I tried this it was returning true in landscape mode when my keyboard wasn't in fullscreen mode.

However, GeckoInputConnection.mIMELandscapeFS is correctly returning false for me in landscape mode. Is it possible that field could be broken for hardware keyboards?
(In reply to Margaret Leibovic [:margaret] from comment #2)

> However, GeckoInputConnection.mIMELandscapeFS is correctly returning false
> for me in landscape mode. Is it possible that field could be broken for
> hardware keyboards?

This field is a hint for the IME - when a VKB is displayed, this flag controls if it should be fullscreen or not. But when HKB is used, the VKB is hidden, so this flag is just not used. Mark is right - I believe you should use imm.isFullscreenMode() to check for the actual VKB state.
(In reply to Alex Pakhotin (:alexp) from comment #3)
> (In reply to Margaret Leibovic [:margaret] from comment #2)
> 
> > However, GeckoInputConnection.mIMELandscapeFS is correctly returning false
> > for me in landscape mode. Is it possible that field could be broken for
> > hardware keyboards?
> 
> This field is a hint for the IME - when a VKB is displayed, this flag
> controls if it should be fullscreen or not. But when HKB is used, the VKB is
> hidden, so this flag is just not used. Mark is right - I believe you should
> use imm.isFullscreenMode() to check for the actual VKB state.

Ah, okay. Do you know what could be causing imm.isFullscreenMode() to return true when I'm in landscape mode with a VKB that isn't actually in fullscreen mode?
Attached patch FixSplinter Review
Use InputMethodManager.isFullscreenMode() to check for the fullscreen VKB mode.
Assignee: margaret.leibovic → alexp
Status: NEW → ASSIGNED
Attachment #589079 - Flags: review?(blassey.bugs)
Attachment #589079 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/e25139fcf302
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Verified on: 
2012-01-18 Firefox/12.0a1 Fennec/12.0a

Bug no longer reproducible on Nightly.
Status: RESOLVED → VERIFIED
Comment on attachment 589079 [details] [diff] [review]
Fix

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Form autocomplete pop-up does not show in landscape with HKB.
Testing completed (on m-c, etc.): Verified on Nightly.
Risk to taking this patch (and alternatives if risky): Low. The change is local and small.
Attachment #589079 - Flags: approval-mozilla-aurora?
Comment on attachment 589079 [details] [diff] [review]
Fix

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #589079 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.