Last Comment Bug 718032 - Make stackwalking for other threads cheaper on Windows by avoiding involving a third walker thread
: Make stackwalking for other threads cheaper on Windows by avoiding involving ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: :Ehsan Akhgari
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on:
Blocks: 713227
  Show dependency treegraph
 
Reported: 2012-01-13 12:43 PST by :Ehsan Akhgari
Modified: 2012-01-26 16:24 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (4.55 KB, patch)
2012-01-13 12:44 PST, :Ehsan Akhgari
jmuizelaar: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2012-01-13 12:43:58 PST
NS_StackWalk for other threads on Windows needs to be as cheap as possible, since we use it in the built-in profiler (bug 718025).

I have a patch which avoids the overhead of using a third thread if we are walking the stack of another thread.
Comment 1 :Ehsan Akhgari 2012-01-13 12:44:51 PST
Created attachment 588498 [details] [diff] [review]
Patch (v1)
Comment 3 Benoit Girard (:BenWa) 2012-01-18 14:54:45 PST
Ignore that last comment, wrong bug #
Comment 4 David Baron :dbaron: ⌚️UTC-10 2012-01-19 14:46:21 PST
It would be nice if you found somebody else to review this (preferably somebody who does fewer reviews).
Comment 5 :Ehsan Akhgari 2012-01-20 13:38:50 PST
Comment on attachment 588498 [details] [diff] [review]
Patch (v1)

Sure.  Jeff, wanna take a stab at this?
Comment 7 Marco Bonardo [::mak] 2012-01-26 16:24:23 PST
https://hg.mozilla.org/mozilla-central/rev/688b672929ca

Note You need to log in before you can comment on or make changes to this bug.