Can't overwrite one character by paste (plaintext)

VERIFIED FIXED in mozilla0.9.6

Status

()

Core
Editor
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.6
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE; 1 day)

(Reporter)

Description

17 years ago
Can't overwrite one character by paste in mail compose window.

abcdef

(1) Select 'c' and hit Ctrl+C.
(2) Select 'e' and hit Ctrl+V. 'e' is pasted, not 'c'.

This is reproducable with Win and Linux build.

Comment 1

17 years ago
Reproducible only with plain text composition window, mar12 commercial trunk
build.  HTML window is fine, doesn't happen in editor, either.
QA Contact: esther → laurel

Comment 2

17 years ago
what about the plain text editor?  can it be reproduced there?
what build is being used?  (hint: today's is NOT a good day for mail compose or 
Composer)

Comment 3

17 years ago
As I mentioned, I'm using mar12 build.  Currently 2001-03-12-04 win98.  I'm not
sure what you mean by the plain text editor.  I did indeed reproduce in the
plain text message compose window.

Comment 4

17 years ago
OK, I understand this now.
If the selection (in step 2) is more than 1 character or just a caret, everything 
is fine.  But if the selection is one character then the paste fails to do 
anything (except remove the selection).

This is probably an editor bug since I can reproduce it in the plaintext editor 
(Debug menu in Composer).

cc kin and joe since they may have an idea on this bug.
Depends on: 28385
No longer depends on: 28385

Comment 5

17 years ago
-->editor
Component: Composition → Editor
Product: MailNews → Browser
Summary: Can't overwrite one character by paste → Can't overwrite one character by paste (plaintext)
reassign to the right person.
Assignee: ducarroz → kin
QA Contact: laurel → sujay
(Assignee)

Comment 7

17 years ago
snarf
Assignee: kin → jfrancis
Whiteboard: EDITORBASE; 1 day
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 8

17 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
Verified on build 2001110903
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.