Closed Bug 718356 Opened 8 years ago Closed 8 years ago

remove Debug > XUL Test Suite menu of failing tests

Categories

(SeaMonkey :: UI Design, defect)

SeaMonkey 2.7 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: info, Assigned: ewong)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20120105 Firefox/10.0 SeaMonkey/2.7
Build ID: 20120105142531

Steps to reproduce:

Try anything in the Debug > XUL Test Suite menu that's in my 2.7b3 Linux x64 SeaMonkey build.


Actual results:

Everything in this menu results in XML Parsing Error. I filed bug 718351 , turns out this is by design because Mozilla disallows "XUL elements in a non-XUL remote".


Expected results:

Back in bug 718351, jsicking commented "If you load XUL using chrome:// urls it should work just fine, but you can probably not load these test pages that way without installing them as an addon." Until then it seems there's no point in having this broken submenu in SeaMonkey builds any more.  It's in http://mxr.mozilla.org/comm-central/source/suite/debugQA/content/debugQAMenuOverlay.xul
> It's in http://mxr.mozilla.org/comm-central/source/suite/debugQA/content/debugQAMenuOverlay.xul
Most of the links appear to redirect to www-archive.mozilla.org

> 134             <menuitem label="#0 Remote XBL"
Does Mozilla/Gecko support remote XBL these days?
I suggest that (personpower permitting) we repackage these tests into the debugQA XPI.
Depends on: 718351
>Does Mozilla/Gecko support remote XBL these days?
No, remote XUL is disabled in newer Geckos
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #589088 - Flags: review?(iann_bugzilla)
Attachment #589088 - Flags: review?(iann_bugzilla) → review+
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/2451261c298f
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.