Last Comment Bug 718494 - nsHTMLTableSectionElement.cpp:188:12: error: variable 'rv' set but not used [-Werror=unused-but-set-variable]
: nsHTMLTableSectionElement.cpp:188:12: error: variable 'rv' set but not used [...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: mozilla12
Assigned To: Oleg Romashin (:romaxa)
:
: Andrew Overholt [:overholt]
Mentors:
: 716904 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-16 12:20 PST by Oleg Romashin (:romaxa)
Modified: 2012-01-17 18:28 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
rv set but not used (2.72 KB, patch)
2012-01-16 12:20 PST, Oleg Romashin (:romaxa)
Ms2ger: review-
Details | Diff | Splinter Review
rv set but not used, use it (2.56 KB, patch)
2012-01-16 13:42 PST, Oleg Romashin (:romaxa)
Ms2ger: review+
Details | Diff | Splinter Review

Description Oleg Romashin (:romaxa) 2012-01-16 12:20:44 PST
Created attachment 588959 [details] [diff] [review]
rv set but not used

Tried to compile FF desktop with default config and warnings as errors param, and got it fail to compile.

most likely blocking bug 698275
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2012-01-16 12:22:41 PST
Comment on attachment 588959 [details] [diff] [review]
rv set but not used

Please add NS_ENSURE_SUCCESS(rv, rv); after all these assignments instead.
Comment 2 Oleg Romashin (:romaxa) 2012-01-16 13:42:24 PST
Created attachment 588990 [details] [diff] [review]
rv set but not used, use it
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-01-17 00:24:56 PST
Comment on attachment 588990 [details] [diff] [review]
rv set but not used, use it

Looks good, thanks.
Comment 4 Mounir Lamouri (:mounir) 2012-01-17 01:22:57 PST

*** This bug has been marked as a duplicate of bug 716904 ***
Comment 5 Joe Drew (not getting mail) 2012-01-17 17:55:08 PST
This was pushed to inbound by Ms2ger, then merged to central:

https://hg.mozilla.org/integration/mozilla-inbound/rev/2613bbdae8c6
https://hg.mozilla.org/mozilla-central/rev/2613bbdae8c6
Comment 6 Mats Palmgren (:mats) 2012-01-17 18:28:02 PST
*** Bug 716904 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.