Problem when forwarding attachment filenames with accented characters

RESOLVED DUPLICATE of bug 1026989

Status

Thunderbird
General
P1
critical
RESOLVED DUPLICATE of bug 1026989
6 years ago
8 months ago

People

(Reporter: Francisco Leandro, Unassigned)

Tracking

9 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

I have forwarded some mails from Gmail users.


Actual results:

When I forward a message, the attachment filenames with accented characters (like á, é, í, ó and ú) have been replaced by only a question mark (?).


Expected results:

Attachment filenames with accented characters should have been maintained as they are.
(Reporter)

Updated

6 years ago
Severity: normal → critical
Priority: -- → P1

Comment 1

6 years ago
(In reply to Francisco Leandro from comment #0)
Probably a duplicate of bug 701818.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 701818
Duping to bug 716983 for ease of tracking.
Duplicate of bug: 716983
Duplicate of bug: 1026989
Root cause of "charset is pcked up from last attachment" was resolved by bug 1026989 at last.

Some valuable bug reports from users were hidden/lost/ignored by "duping to bug 716983, then duping bug 716983 to other bug".
Unfortunately, or fotunately, only "garbled display in Forward Inline case" was resolved by unknown bug while the other bug was being processed, so nothing was resolved by the other bug.

Duping this bug to bug 1026989, for ease of tracking, search, understanding current status of problem.
FYI.
Patch of bug 1026989, one liner patch, was proposed in the other bug to which bug 716983(and bug 701818 too) had been duped to. The patch was dig out from the other bug by bug 1026989, and long lived "charset is picked up from last attachment" issue has been resolved by bug 1026989.

Why such "digging out hidden important patch from the other bug" should be needed in B.M.O?
You need to log in before you can comment on or make changes to this bug.