Last Comment Bug 719042 - Tilt should use the new Highlighter API
: Tilt should use the new Highlighter API
Status: RESOLVED FIXED
[tilt]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 13
Assigned To: Victor Porof [:vporof][:vp]
:
: Patrick Brosset <:pbro>
Mentors:
Depends on: 715970
Blocks: 723435
  Show dependency treegraph
 
Reported: 2012-01-18 07:56 PST by Victor Porof [:vporof][:vp]
Modified: 2012-02-27 00:59 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (2.76 KB, patch)
2012-01-29 10:14 PST, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2012-01-18 07:56:36 PST

    
Comment 1 Victor Porof [:vporof][:vp] 2012-01-29 10:14:15 PST
Created attachment 592519 [details] [diff] [review]
v1

There is one line change in inspector.jsm.
I moved "this.highlighter.highlight();" before sending the OPENED notification, because when switching tabs, Tilt needs to call "this.highlighter.hide();". If this hide() call is made before the highlight() action, it won't have any effect because line 293 in highlighter.jsm: "if (this.hidden) return;". This means that the "hidden" flag isn't updated to false when the OPENED observer in Tilt calls hide(), which makes the highlighter always show above Tilt when switching tabs.
This behavior wasn't present before because I was setting the actual highlighter-container display to "none", a state which isn't modified by the highlighter internally.
Comment 2 Victor Porof [:vporof][:vp] 2012-01-30 00:26:35 PST
Comment on attachment 592519 [details] [diff] [review]
v1

https://tbpl.mozilla.org/?tree=Try&rev=ce9d3ecd89e5
Comment 3 Rob Campbell [:rc] (:robcee) 2012-02-24 06:46:01 PST
https://hg.mozilla.org/integration/fx-team/rev/e71292cac3d2
Comment 4 Tim Taubert [:ttaubert] 2012-02-27 00:59:49 PST
https://hg.mozilla.org/mozilla-central/rev/e71292cac3d2

Note You need to log in before you can comment on or make changes to this bug.