Closed Bug 719527 Opened 8 years ago Closed 3 years ago

Enable input suggestions for the AwesomeBar when it's in Search mode

Categories

(Firefox for Android :: Keyboards and IME, defect, P3)

ARM
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking-fennec1.0 --- -
fennec + ---

People

(Reporter: alexp, Unassigned, Mentored)

References

Details

(Keywords: inputmethod)

We had to disable autocompletion in the AwesomeBar due to the issues with Swype and Samsung IME: bug 712972 and bug 718909. It solved the problem with typed URLs, but made using Search mode less convenient, as no suggestions are shown.

We should try to enable the suggestions when the AwesomeBar is in Search mode. The flag InputType.TYPE_TEXT_FLAG_NO_SUGGESTIONS is the key:
http://developer.android.com/reference/android/text/InputType.html#TYPE_TEXT_FLAG_NO_SUGGESTIONS
tracking-fennec: --- → +
Assignee: nobody → cpeterson
Version: unspecified → Trunk
Flags: blocking-fennec1.0?
I don't think this bug should be a 1.0 blocker. The behavior is inconvenient, but does not prevent the user from searching.
Minus based on comment 1.
tracking-fennec: + → -
blocking-fennec1.0: --- → ?
tracking-fennec: - → +
blocking-fennec1.0: ? → -
Triage, this bug needs a priority.
blocking-fennec1.0: - → ?
blocking-fennec1.0: ? → -
Component: General → IME
Depends on: 712972
Hardware: All → ARM
Duplicate of this bug: 755944
Priority: -- → P3
Flags: blocking-fennec1.0?
Assignee: cpeterson → nobody
Whiteboard: [mentor=jchen]
Mentor: nchen
Whiteboard: [mentor=jchen]
is it a still valid bug ?
Outside private mode, suggestions were unconditionally re-enabled in bug 1320449 - as I didn't know about the history of bug 712972 and bug 718909 then, we might at least want to check with a few different IMEs that those sort of bugs are no longer relevant.

At least for bug 718909 (which was about the Samsung keyboard) I can say that my old phone was a S3 Mini (which was probably a bit more recent than mfinkle's phone at the time of that bug) and the Samsung keyboard
- ignored textNoSuggestion anyway
- but I didn't notice any text in the URL bar being eaten because of input suggestions, either

so it seems like Samsung fixed that issue on their side at some point.
(In reply to Jan Henning [:JanH] from comment #6)
> Outside private mode, suggestions were unconditionally re-enabled in bug
> 1320449 - as I didn't know about the history of bug 712972 and bug 718909
> then, we might at least want to check with a few different IMEs that those
> sort of bugs are no longer relevant.
> 
> At least for bug 718909 (which was about the Samsung keyboard) I can say
> that my old phone was a S3 Mini (which was probably a bit more recent than
> mfinkle's phone at the time of that bug) and the Samsung keyboard
> - ignored textNoSuggestion anyway
> - but I didn't notice any text in the URL bar being eaten because of input
> suggestions, either
> 
> so it seems like Samsung fixed that issue on their side at some point.

Thanks for the prompt reply.  
I wonder if we could RESOLVED WORKSFORME this bug now. 
It hasn't been updated for more than two years, and we're grooming Fennec backlog recently.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.