The default bug view has changed. See this FAQ.

Scheme-less URLs references in the style sheet are lost when editing

RESOLVED FIXED in Firefox 15

Status

()

Firefox
Developer Tools: Style Editor
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Kevin Dangoor, Assigned: cedricv)

Tracking

unspecified
Firefox 16
Points:
---

Firefox Tracking Flags

(firefox15 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
If you change a background (on the HTML element, at least) with an image and then change it back, the background image does not come back.

STR:

1. go to http://hacks.mozilla.org/
2. edit the html {} rule that sets the background image (say remove the "u" in "url)
3. put the u back in

You'll see that the background image is gone, even though the rule is back to where it started.
(Reporter)

Updated

5 years ago
Priority: -- → P2

Comment 1

5 years ago
This happens only for non-absolute URLs. We are moving the style in an inline stylesheet. So some URL can become invalid.
(Assignee)

Updated

5 years ago
Assignee: nobody → cedricv
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Summary: During editing, background images disappear and don't come back → During editing, background images with relative URIs disappear

Comment 2

5 years ago
And I think this is also the reason why some font-faces stop working.

I would P1 that. It breaks quite a lot of websites and it makes the StyleEditor experience a bit "unpredictable".
yeah, definitely bumping priority if this is causing breakage.
Priority: P2 → P1
ps, still open to recommendations on that method name!

Comment 5

5 years ago
(In reply to Rob Campbell [:rc] (robcee) from comment #4)
> ps, still open to recommendations on that method name!

I think you meant to comment there: bug 705707
uh disregard comment 4.
(Assignee)

Updated

5 years ago
Summary: During editing, background images with relative URIs disappear → Scheme-less URLs style sheet references are lost when editing
(Assignee)

Updated

5 years ago
Summary: Scheme-less URLs style sheet references are lost when editing → Scheme-less URLs references in the style sheet are lost when editing
(Assignee)

Updated

5 years ago
Depends on: 727834
(Assignee)

Comment 7

5 years ago
Created attachment 599948 [details] [diff] [review]
patch v1 - use the new ParseStyleSheet API
Attachment #599948 - Flags: review?(rcampbell)
Comment on attachment 599948 [details] [diff] [review]
patch v1 - use the new ParseStyleSheet API

nice.
Attachment #599948 - Flags: review?(rcampbell) → review+
you might want to run this through try server before landing, but I leave that up to you. Not sure if your try run from the blocking bug includes this patch or not.
(Assignee)

Comment 10

5 years ago
(In reply to Rob Campbell [:rc] (robcee) from comment #9)
> you might want to run this through try server before landing, but I leave
> that up to you. Not sure if your try run from the blocking bug includes this
> patch or not.

It does and it's all green yay :)

Comment 11

5 years ago
Is this ready to land?
(Assignee)

Comment 12

5 years ago
(In reply to Paul Rouget [:paul] from comment #11)
> Is this ready to land?

Nope, it has a dependency on bug 727834.

Comment 13

5 years ago
What are the chances to fix bug 727834 soon (before Firefox 14 cut)? If you think it will take time, can we get a temporary solution for this bug?

Updated

5 years ago
Duplicate of this bug: 760994

Comment 15

5 years ago
Now that bug 727834 is fixed, can we land this patch?

Comment 16

5 years ago
And could we get that in 15?
(Assignee)

Comment 17

5 years ago
Yes and this is indeed a good candidate for aurora-approval as this is an important bug fix which consists of a small (more lines removed than added in actual code) and low-risk change on the JavaScript side.
Hardware: x86 → All
Whiteboard: [land-in-fx-team]

Comment 18

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/45d4ea8d17aa
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]

Comment 19

5 years ago
Comment on attachment 599948 [details] [diff] [review]
patch v1 - use the new ParseStyleSheet API

[Approval Request Comment]
Bug caused by (feature/regressing bug #): not a regression (never worked correctly)
User impact if declined: the style editor fails often
Testing completed (on m-c, etc.): several try-runs, locally tested
Risk to taking this patch (and alternatives if risky): quite short, not too risky
String or UUID changes made by this patch: none
Attachment #599948 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/45d4ea8d17aa
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 16
Comment on attachment 599948 [details] [diff] [review]
patch v1 - use the new ParseStyleSheet API

[Triage Comment]
Early enough in the cycle to take a fix for Aurora 15, even though this has non-zero risk.
Attachment #599948 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/210f12d591a7
status-firefox15: --- → fixed
You need to log in before you can comment on or make changes to this bug.