To: or CC: headers with multiple recipients are displayed incorrectly

VERIFIED FIXED in mozilla0.8.1

Status

SeaMonkey
MailNews: Message Display
P1
normal
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: blizzard, Assigned: David Hyatt)

Tracking

({regression})

Trunk
mozilla0.8.1
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+]critical to mozilla 0.8.1 - have patch w/reviews ready to go)

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
If you get a piece of email with a To: or CC: have the commas displayed in the
wrong place.  I'll attach a screenshot in a second.
(Reporter)

Comment 1

17 years ago
Created attachment 27693 [details]
screenshot
(Reporter)

Comment 2

17 years ago
Created attachment 27694 [details]
screenshot
(Reporter)

Comment 3

17 years ago
OK, file uploading is screwed so I can't upload the entire image but if you look
you can see how the commas are before the list of recipeints.  I seem to
remember some header parsing changes recently.
Whiteboard: critical to mozilla 0.8.1
*** Bug 71964 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
same on Win32 2001-0314-04

Comment 6

17 years ago
Also noticed in mar13 commercial trunk builds.
Keywords: nsbeta1, regression
QA Contact: esther → laurel

Comment 7

17 years ago
*** Bug 71978 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
moving info from dup bug I filed and reassigning to racham.
Assignee: sspitzer → racham
Whiteboard: critical to mozilla 0.8.1 → [nsbeta1+]critical to mozilla 0.8.1
Target Milestone: --- → mozilla0.8.1

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

17 years ago
Priority: -- → P1

Comment 9

17 years ago
Hyatt thinks he probably caused this with his latest checkins. Reassigning to
him and adding myself to the cc list.
Assignee: racham → hyatt
Status: ASSIGNED → NEW
(Assignee)

Comment 10

17 years ago
Created attachment 27808 [details] [diff] [review]
Patch to the skins
(Assignee)

Comment 11

17 years ago
Created attachment 27810 [details] [diff] [review]
Patch to global
(Assignee)

Comment 12

17 years ago
Let me take this opportunity to complain about the need for *content* CSS.  Not
all CSS is skin-related!  In particular, rules involving display and visibility
should be loaded from content CSS files (just as we do with xul.css, which is in
content not skin).

I had to make the same change in five different skin files!  All the rules were
the same!  Refactor this into your content and don't force every skin to
duplicate these rules!

:)
Status: NEW → ASSIGNED

Comment 13

17 years ago
sr=mscott

Comment 15

17 years ago
Applied patch to my local tree.

Things look good both on Modern and Commercial skins.

Updated

17 years ago
Whiteboard: [nsbeta1+]critical to mozilla 0.8.1 → [nsbeta1+]critical to mozilla 0.8.1 - have patch w/reviews ready to go

Comment 16

17 years ago
a=asa for 0.8.1 checkin on behalf of drivers.  
(Assignee)

Comment 17

17 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 18

17 years ago
OK using apr16 commercial trunk build: linux rh6.2, mac OS 9.0, win98
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.