Closed Bug 719741 Opened 8 years ago Closed 8 years ago

Crash @ __libc_android_abort | dlfree | free | fclose

Categories

(Firefox for Android :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 725736
Tracking Status
firefox12 --- affected

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash])

Crash Data

It's currently #3 top crasher over the last 3 days in 12.0a1.
It first appeared in 12.0a1/20120113125827. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8ffdb4c7404a&tochange=790cd9bba7f5

Signature 	__libc_android_abort | dlfree | free | fclose More Reports Search
UUID	0c9ebd45-fb62-4c45-bd38-58f672120120
Date Processed	2012-01-20 00:47:18
Uptime	821
Last Crash	4.6 days before submission
Install Age	3.9 days since version was first installed.
Install Time	2012-01-16 02:00:15
Product	FennecAndroid
Version	12.0a1
Build ID	20120115031052
Release Channel	nightly
OS	Linux
OS Version	0.0.0 Linux 2.6.35.7-N7000DXKK1-CL706642 #2 SMP PREEMPT Thu Nov 3 21:34:34 KST 2011 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0xdeadbaad
App Notes 	
EGL? EGL+
AdapterVendorID: smdkc210, AdapterDeviceID: GT-N7000.
AdapterDescription: 'Android, Model: 'GT-N7000', Product: 'GT-N7000', Manufacturer: 'samsung', Hardware: 'smdkc210''.
samsung GT-N7000
samsung/GT-N7000/GT-N7000:2.3.5/GINGERBREAD/DXKK1:user/release-keys	
EMCheckCompatibility	True

Frame 	Module 	Signature 	Source
0 	libc.so 	__libc_android_abort 	
1 	libc.so 	dlfree 	
2 	libc.so 	free 	
3 	libc.so 	fclose 	
4 	libc.so 	getaddrinfo 	
5 	libc.so 	nsdispatch 	
6 	libc.so 	freeaddrinfo 	
7 	libc.so 	getaddrinfo 	
8 	libnspr4.so 	PR_GetAddrInfoByName 	nsprpub/pr/src/misc/prnetdb.c:2079
9 	libxul.so 	nsHostResolver::ThreadFunc 	netwerk/dns/nsHostResolver.cpp:958
10 	libnspr4.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c:187
11 	libc.so 	__thread_entry 	
12 	libc.so 	pthread_create 	

More reports at:
https://crash-stats.mozilla.com/report/list?product=FennecAndroid&version=FennecAndroid%3A12.0a1&range_value=28&range_unit=days&signature=__libc_android_abort%20|%20dlfree%20|%20free%20|%20fclose
Keywords: regression
(In reply to Naoki Hirata :nhirata from comment #1)
> http://www.google.com/m?ie=UTF-8&oe=UTF-
> 8&sourceid=navclient&gfns=1&q=dead+space+cheat
> http://www.kongozan.com/live/index2.html

are these urls what's causing the crash?
These 2 URLs are sample URLs that have left the crash signatures.  I tried to repro the crashes, however I was unable to do so going to these two sites.
tracking-fennec: --- → ?
fixed by 725736
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 725736
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.